x11-terms/gnome-terminal: bump to 3.34.2
authorMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 16:21:13 +0000 (18:21 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 16:22:04 +0000 (18:22 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-terms/gnome-terminal/Manifest
x11-terms/gnome-terminal/gnome-terminal-3.34.2.ebuild [new file with mode: 0644]

index 7a305b3efb7b0a4d3744db3239151b447cc310f0..9d99e341477f81ecb3b2cbb6520db82d944603e9 100644 (file)
@@ -1,2 +1,5 @@
 DIST gnome-terminal-3.32.2-cntr-ntfy-ttl-ts.patch.xz 31684 BLAKE2B 34c3473632d82983aec98a867e7353829521527f8f570e62e5fd7a1bd638b470c6f1ce7fde33d4604a2ca40e4b93be02a22dbdd4d1559a03bf230060310e81bf SHA512 76732fd57644431936b78a3ea3e8010b3f14fb0af52fa9c79540ed5ec5a0a45e6b31c9ace2b67a02559ec4e294927bf2033730d074727c3fe05054f39d1a8b42
 DIST gnome-terminal-3.32.2.tar.xz 2039236 BLAKE2B 967f87a362cf893c8d743caefc9b857d6c8092e59c3ce77a76dea5d50f503bea9c9e066e447724b6c7781bec808a4cccf8c3d646ecccb1800da9a0bdd7f28e4d SHA512 1be1e26b62b9364361982a34455fb5c818a2114edadb1146985f9e418ce5d51387d12b443c12022b8eec9c61c2137a1a780f390672406a1940f8b352b782e3cc
+DIST gnome-terminal-3.34.2-cntr-ntfy-autottl-ts.patch.xz 33896 BLAKE2B 3f52a9ca3223abde8df3ecb97129d4d9078384353f187703ea27b3c2797432fae8edf85a442578c75ca26e8ff61b5b444e69c92a7fa6f61229c3bf1f8cfeef2c SHA512 bd48b85ea87863a077333493f4b2146c383d2a137d32cf535fc35a2fc76c738b6aaf56da23a7dae469545af9fac75fa756a18e946e39cbb6eba0bc41707f869a
+DIST gnome-terminal-3.34.2-patchset.tar.xz 33120 BLAKE2B d052dc1b425b298d0eca6664d43b0a3fb32e362852f93fb4c736b68f0f0be785cb8d4da3d341fef5abeb881fe6adf7acf1c716166241ecbe60513ac7d4fabe2b SHA512 3a6f9e2a2b04368dd6b3098bd0399cb784f8702b4d23415dc8efe828aa12591a327ff31d0739a19deed0736a6d0a70cbc643c2f3cd0a767c67bb1b009d33969e
+DIST gnome-terminal-3.34.2.tar.xz 2045872 BLAKE2B 390235a1674d1ea7c0398f94ccc9e7baa301e9acef42170d512766d2bcd53a9669c3100a9590702234b456a6d33de5cf825cbe9733d6e89422211049187bb86b SHA512 36df7483c2b56df1d9e66729826b1bb65755590498295615befdb89e25d69464ebf4b77928ccd88f069513cb58da2856dca748dbf6372ca145b4535609d76595
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.34.2.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..c32e97d
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz
+!vanilla? ( https://dev.gentoo.org/~leio/distfiles/${P}-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+       >=dev-libs/glib-2.52:2
+       >=x11-libs/gtk+-3.20:3
+       >=x11-libs/vte-0.58.1:2.91[!vanilla?]
+       >=dev-libs/libpcre2-10
+       >=gnome-base/dconf-0.14
+       >=gnome-base/gsettings-desktop-schemas-0.1.0
+       sys-apps/util-linux
+       gnome-shell? ( gnome-base/gnome-shell )
+       nautilus? ( >=gnome-base/nautilus-3 )
+"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+DEPEND="${RDEPEND}
+       dev-libs/libxml2:2
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       >=dev-util/intltool-0.50
+       dev-util/itstool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+       notifications of long-running commands finishing, you will need
+       to add the following line to your ~/.bashrc:\n
+       . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+       eapply "${WORKDIR}"/patches # translation updates; below conditional patch requires it to apply cleanly
+       if ! use vanilla; then
+               # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+               # Fedora patches:
+               # Restore transparency support (with compositing WMs only)
+               # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+               # Restore "Set title" support
+               # Automatic title updating based on currently running foreground process
+               # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+               # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+               eapply "${WORKDIR}"/${P}-cntr-ntfy-autottl-ts.patch
+       fi
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable debug) \
+               $(use_enable gnome-shell search-provider) \
+               $(use_with nautilus nautilus-extension)
+}
+
+src_install() {
+       DOCS="AUTHORS ChangeLog HACKING NEWS"
+       gnome2_src_install
+       if ! use vanilla; then
+               # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+               insinto /usr/share/glib-2.0/schemas
+               newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+       fi
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+       readme.gentoo_print_elog
+}