app-accessibility/orca: Version bump
authorPacho Ramos <pacho@gentoo.org>
Mon, 9 Nov 2015 21:41:44 +0000 (22:41 +0100)
committerPacho Ramos <pacho@gentoo.org>
Mon, 9 Nov 2015 21:51:07 +0000 (22:51 +0100)
Package-Manager: portage-2.2.24

app-accessibility/orca/Manifest
app-accessibility/orca/orca-3.18.2.ebuild [new file with mode: 0644]

index ad663833bd87c1d13e7b9eeafdc56c5271167b29..9c7e424297352afe282795b4e7550b12126933dc 100644 (file)
@@ -1,2 +1,3 @@
 DIST orca-3.16.2.tar.xz 2078728 SHA256 cd14b28878cc04166ec43c7d9a8e6b0056c66cbfb1e4f934f12f74568937789a SHA512 768628c4630d84929a8a2b12b73771de7b104b1754e9462b1fe63c2bbadca192e56416a1e2a43ad5f5594c91a4fe94941d2deb1e44cccaf253d4f03704f31ee1 WHIRLPOOL eea3f9a1a0b1aebb4ca3a6da1a5cf016b1ea6d042c4e8e1b7275325cd08e77c6a7c6519048651ace34ef10d69c22663e9009dab20502ff3fca7d6c6c9a888c9a
 DIST orca-3.16.3.tar.xz 2124800 SHA256 540deeaa1a973cc7ccc8a463f8fcf51db51f7ccfb130bc2019ac53bf67943dc7 SHA512 c579437d956bee014db61aeb7494a295345e28a147a938a71a8062c30de67fcff3767c5ea8767067ce5f2f5ff84c0aaf2fc250730e4a7036ae100078fd6f058f WHIRLPOOL 839b3c7170f2fd44fa5b97cfd9ed6989dd94721d379d21428a166b8321fb5162a56f758327df0ea632bf320711362b0e03916358d023fba8dffec2a36f62b970
+DIST orca-3.18.2.tar.xz 2213548 SHA256 986244af7a0891b758eb8e772bc61d72483808e7e9c790360f9f389045d7262a SHA512 ec1210cea7a540bd931f7ede45c173829e780a4da4e61245920d15bb11b62d803771e32b791b2d0c307e15a8ef61b619b5e79e9909bf438a94252842a0dd8613 WHIRLPOOL 31475d1eacbf322cdd49d286c3585d97c93de08f92b0533fa58905d4ea089272bc16e8bb748041cc6f27dd54c19996b3d72993c5b148b3c8e6c873f9e452fe98
diff --git a/app-accessibility/orca/orca-3.18.2.ebuild b/app-accessibility/orca/orca-3.18.2.ebuild
new file mode 100644 (file)
index 0000000..090e21a
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4,5} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+COMMON_DEPEND="${PYTHON_DEPS}
+       >=app-accessibility/at-spi2-atk-2.12:2
+       >=app-accessibility/at-spi2-core-2.12:2[introspection]
+       >=dev-libs/atk-2.10
+       >=dev-libs/glib-2.28:2
+       >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+       >=x11-libs/gtk+-3.6.2:3[introspection]
+       braille? (
+               >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+               dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+       >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+       dev-libs/atk[introspection]
+       dev-python/pyatspi[${PYTHON_USEDEP}]
+       dev-python/setproctitle[${PYTHON_USEDEP}]
+       x11-libs/libwnck:3[introspection]
+       x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/intltool-0.50
+       dev-util/itstool
+       virtual/pkgconfig
+"
+#      app-text/yelp-tools
+
+src_prepare() {
+       gnome2_src_prepare
+       python_copy_sources
+}
+
+src_configure() {
+       python_foreach_impl run_in_build_dir gnome2_src_configure \
+               $(use_with braille liblouis)
+}
+
+src_compile() {
+       python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+       DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+       installing() {
+               gnome2_src_install
+               # Massage shebang to make python_doscript happy
+               sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+                       -i src/orca/orca || die
+               python_doscript src/orca/orca
+       }
+       python_foreach_impl run_in_build_dir installing
+}