app-admin/keepassxc: Fixed compilation with qt-5.11
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 16 May 2018 09:08:33 +0000 (11:08 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 16 May 2018 09:09:31 +0000 (11:09 +0200)
Thanks to Markus Rathgeb for reporting the bug and providing the fix.

Closes: https://bugs.gentoo.org/655844
Package-Manager: Portage-2.3.36, Repoman-2.3.9

app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch [new file with mode: 0644]
app-admin/keepassxc/keepassxc-2.3.3.ebuild

diff --git a/app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch b/app-admin/keepassxc/files/keepassxc-2.3.3-qt-5.11-edit-entry-widget-includes.patch
new file mode 100644 (file)
index 0000000..c382db5
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/gui/entry/EditEntryWidget.cpp
++++ b/src/gui/entry/EditEntryWidget.cpp
+@@ -32,6 +32,7 @@
+ #include <QMimeData>
+ #include <QEvent>
+ #include <QColorDialog>
++#include <QButtonGroup>
+ #include "autotype/AutoType.h"
+ #include "core/Config.h"
index 69a10050827849598355f00feb4809cf3ef61bd2..3641f74e736c5eb736867a2e3fdcf38288f5cef5 100644 (file)
@@ -47,6 +47,10 @@ DEPEND="
        dev-qt/qtconcurrent:5
 "
 
+PATCHES=(
+       "${FILESDIR}/${P}-qt-5.11-edit-entry-widget-includes.patch" #655844
+)
+
 src_prepare() {
         use test || \
                sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die