app-shells/bashdb: Bump to version 5.0.1.1.0
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 16 Oct 2019 11:18:39 +0000 (13:18 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 16 Oct 2019 11:18:39 +0000 (13:18 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-shells/bashdb/Manifest
app-shells/bashdb/bashdb-5.0.1.1.0.ebuild [new file with mode: 0644]

index 2f70f2f1d7db6957d9cb871393a0dc1a9b5d8007..1503b74caa8335b143416adee8030f5fb1a4d79a 100644 (file)
@@ -4,3 +4,4 @@ DIST bashdb-4.4-0.94.tar.bz2 810610 BLAKE2B fa3a68349b0ab64e17c094c34b82c8ba054a
 DIST bashdb-4.4-1.0.0-missing-test-files.tar.xz 996 BLAKE2B 7ea67884cceda11559cf49355645cad2cfd485537643ad2fa05398518f498163596b6f591756bedd0e7b7e013fed3c6a031e245d15cd0cf316d42ef4f5c8b3e6 SHA512 e19d41569c2001ce026e4c5f80cc21c81651ff9980be059236c45e215162769ceda266eb46aa4199000e377c0bb53dec98fa1b7c5290459c412f21329b3589a5
 DIST bashdb-4.4-1.0.0.tar.bz2 701749 BLAKE2B 2fa4bfd21f6c646c6bb1c2439dfed870478fb985dd52c8ba716e08fa0312da9adb0c29396594280bce525bb88f15b7398878c7a9bb2a39c078d4e5f17706c20a SHA512 eae45eb221c662e6bbf86814b861992944fcdef221e1bbc7df6c4fd0197022b82fabf4b7e5d583ba4fff94a0b486f71901d42f9df12a8b6a5f564e9236ad37e5
 DIST bashdb-4.4-1.0.1.tar.bz2 701807 BLAKE2B 8d41a39831ce9466f5fcd205cf84e337ca7d876fddaea8b8c013fe4ac93a143c9f5b5e46bcc8edbb50fe4c77e87bd282ff9a244e41df007897d3b37f732bb0a3 SHA512 306fc5a49490fe04828cd6c64b23302e0f48ba8558780c93d45d9c615206e91dac5d8ff3d0660e50bc3204873131d1296492bccc23119d2f58c990bd3603221c
+DIST bashdb-5.0-1.1.0.tar.bz2 693459 BLAKE2B f8697c0f4a10b57215b0923cfb49c76536cc75de5273e6ed1709aaa56fcced8c5b3f281f15f01b8bd72363ad7c47acbd6d06a3bb3ba58b9a2daae017c101ae46 SHA512 0da69ea426c57d2f2b3f208356ee893b3fa8b96c68bf321446b5747b6bfb2eac502be6a01e3922fa873684a3953c6a3ded4a30f5682e4030680d698ee5062143
diff --git a/app-shells/bashdb/bashdb-5.0.1.1.0.ebuild b/app-shells/bashdb/bashdb-5.0.1.1.0.ebuild
new file mode 100644 (file)
index 0000000..d83f406
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2
+       test? ( https://dev.gentoo.org/~whissi/dist/bashdb/bashdb-4.4-1.0.0-missing-test-files.tar.xz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       if use test ; then
+               einfo "Copying missing files ..."
+               # https://sourceforge.net/p/bashdb/bugs/52/
+               cp -vafn "${WORKDIR}"/missing-files/* "${S}"/test || die
+       fi
+
+       default
+
+       # We don't install this, so don't bother building it. #468044
+       sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+       # This path matches the bash sources.  If we ever change bash,
+       # we'll probably have to change this to match.  #591994
+       econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}