dev-perl/Data-ShowTable: Fix test failure without '.' in @INC bug #615582
authorKent Fredric <kentnl@gentoo.org>
Sat, 7 Oct 2017 06:30:25 +0000 (19:30 +1300)
committerKent Fredric <kentnl@gentoo.org>
Sat, 7 Oct 2017 06:32:21 +0000 (19:32 +1300)
- Fix parallel testing and enable it
- Restore disabled test which I cannot make fail.

Bug: https://bugs.gentoo.org/403881
Closes: https://bugs.gentoo.org/615582
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Data-ShowTable/Data-ShowTable-4.600.0.ebuild
dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-parallel.patch [new file with mode: 0644]
dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-perl526.patch [new file with mode: 0644]

index d42abe99df4c0e9679a49eaafc443f241f8a32ca..ffd4367a7e498b11382cc4dbad554f899468590a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -16,12 +16,9 @@ IUSE=""
 
 DEPEND="virtual/perl-ExtUtils-MakeMaker"
 
-SRC_TEST=do
+SRC_TEST="do parallel"
 
-src_test() {
-       # When version bumping the package next time,
-       # please comment out the line below to see if this test passes.
-       # bug 403881
-       perl_rm_files t/list-wrap.t
-       perl-module_src_test
-}
+PATCHES=(
+       "${FILESDIR}/${P}-perl526.patch"
+       "${FILESDIR}/${P}-parallel.patch"
+)
diff --git a/dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-parallel.patch b/dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-parallel.patch
new file mode 100644 (file)
index 0000000..998b11c
--- /dev/null
@@ -0,0 +1,32 @@
+From a4db786271c4ae3b987d7c4facc488db31966221 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 7 Oct 2017 19:17:38 +1300
+Subject: Fix parallel testing issues by using a non-concurrent tempdir
+
+(Possible) Bug: https://bugs.gentoo.org/403881
+Bug: https://rt.cpan.org/Ticket/Display.html?id=102615
+---
+ t/Test-Setup.pl | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/Test-Setup.pl b/t/Test-Setup.pl
+index 8b4a82e..f7400cd 100755
+--- a/t/Test-Setup.pl
++++ b/t/Test-Setup.pl
+@@ -1,11 +1,11 @@
+ #!/usr/bin/env perl
+ use Carp;
+-
++use File::Temp qw( tempdir );
+ ($DIR,$PROG) = $0 =~ m=^(.*/)?([^/]+)$=;
+ $DIR =~ s=/$== || chop($DIR = `pwd`);
+-$testdir = -d 't' ? 't' : '.';
++$testdir = tempdir( 'temp.XXXX', DIR => ( -d 't' ? 't' : '.' ), CLEANUP => 1);
+ # Setup these globals
+-- 
+2.14.1
+
diff --git a/dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-perl526.patch b/dev-perl/Data-ShowTable/files/Data-ShowTable-4.600.0-perl526.patch
new file mode 100644 (file)
index 0000000..d779488
--- /dev/null
@@ -0,0 +1,236 @@
+From 9a7d82a8994505ad4c6552540d26c7586073e459 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 7 Oct 2017 19:08:53 +1300
+Subject: Fix test failures on Perl 5.26
+
+This also replaces "do" with a stricter 'require' as that will properly
+fail on nested errors instead of silently failing
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121132
+Bug: https://bugs.gentoo.org/615582
+---
+ t/box-calls.t        | 2 +-
+ t/box-scaling.t      | 2 +-
+ t/box-showtable.t    | 2 +-
+ t/box-widths.t       | 2 +-
+ t/box-wrap.t         | 2 +-
+ t/html-calls.t       | 2 +-
+ t/html-scaling.t     | 2 +-
+ t/html-showtable.t   | 2 +-
+ t/html-widths.t      | 2 +-
+ t/html-wrap.t        | 2 +-
+ t/list-calls.t       | 2 +-
+ t/list-scaling.t     | 2 +-
+ t/list-showtable.t   | 2 +-
+ t/list-widths.t      | 2 +-
+ t/list-wrap.t        | 2 +-
+ t/simple-calls.t     | 2 +-
+ t/simple-scaling.t   | 2 +-
+ t/simple-showtable.t | 2 +-
+ t/simple-widths.t    | 2 +-
+ t/simple-wrap.t      | 2 +-
+ 20 files changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/t/box-calls.t b/t/box-calls.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/box-calls.t
++++ b/t/box-calls.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/box-scaling.t b/t/box-scaling.t
+index 74a1ad9..c95e2fd 100755
+--- a/t/box-scaling.t
++++ b/t/box-scaling.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl"
+diff --git a/t/box-showtable.t b/t/box-showtable.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/box-showtable.t
++++ b/t/box-showtable.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/box-widths.t b/t/box-widths.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/box-widths.t
++++ b/t/box-widths.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/box-wrap.t b/t/box-wrap.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/box-wrap.t
++++ b/t/box-wrap.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/html-calls.t b/t/html-calls.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/html-calls.t
++++ b/t/html-calls.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/html-scaling.t b/t/html-scaling.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/html-scaling.t
++++ b/t/html-scaling.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/html-showtable.t b/t/html-showtable.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/html-showtable.t
++++ b/t/html-showtable.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/html-widths.t b/t/html-widths.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/html-widths.t
++++ b/t/html-widths.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/html-wrap.t b/t/html-wrap.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/html-wrap.t
++++ b/t/html-wrap.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/list-calls.t b/t/list-calls.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/list-calls.t
++++ b/t/list-calls.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/list-scaling.t b/t/list-scaling.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/list-scaling.t
++++ b/t/list-scaling.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/list-showtable.t b/t/list-showtable.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/list-showtable.t
++++ b/t/list-showtable.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/list-widths.t b/t/list-widths.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/list-widths.t
++++ b/t/list-widths.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/list-wrap.t b/t/list-wrap.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/list-wrap.t
++++ b/t/list-wrap.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/simple-calls.t b/t/simple-calls.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/simple-calls.t
++++ b/t/simple-calls.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/simple-scaling.t b/t/simple-scaling.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/simple-scaling.t
++++ b/t/simple-scaling.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/simple-showtable.t b/t/simple-showtable.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/simple-showtable.t
++++ b/t/simple-showtable.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/simple-widths.t b/t/simple-widths.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/simple-widths.t
++++ b/t/simple-widths.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+diff --git a/t/simple-wrap.t b/t/simple-wrap.t
+index 74a1ad9..ee6e26d 100755
+--- a/t/simple-wrap.t
++++ b/t/simple-wrap.t
+@@ -25,4 +25,4 @@ $what = "t/$what" if -d "t" && !-r "$what.pl";
+ unshift(@INC,'../blib/lib') if -d '../blib/lib';
+ unshift(@INC,'t') if -d 't';
+-do "$what.pl";
++require "./$what.pl";
+-- 
+2.14.1
+