sci-calculators/datamash: Fix patch/drop autotools.eclass.
authorJeroen Roovers <jer@gentoo.org>
Wed, 23 Aug 2017 22:09:06 +0000 (00:09 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 23 Aug 2017 22:09:31 +0000 (00:09 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

sci-calculators/datamash/datamash-1.2.ebuild
sci-calculators/datamash/files/datamash-1.2-libcrypto.patch

index 87c7f2fe928a5ef5afc0781f209452a929b85df6..2046d05d80fa9932c8dd76ffddbe96beaa63eaaa 100644 (file)
@@ -2,7 +2,6 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools
 
 DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
 HOMEPAGE="https://www.gnu.org/software/datamash/"
@@ -28,12 +27,6 @@ PATCHES=(
        "${FILESDIR}"/${PN}-1.2-libcrypto.patch
 )
 
-src_prepare() {
-       default
-
-       eautoreconf
-}
-
 src_configure() {
        econf \
                $(use_enable nls) \
index ef1f32e9855d728f0b6b0e5ea0f6561a9004d0b3..887d807ec04be4bbe2ecc3798f9be8ecda8c4cab 100644 (file)
@@ -8,3 +8,23 @@
         $(ROUND_LIBM) \
         $(ROUNDL_LIBM) \
         $(SQRT_LIBM) \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -339,7 +339,8 @@
+       $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+       $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+       $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+-      $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
++      $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
++      $(am__DEPENDENCIES_1)
+ datamash_LINK = $(CCLD) $(datamash_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
+       $(LDFLAGS) -o $@
+ AM_V_P = $(am__v_P_@AM_V@)
+@@ -1908,6 +1909,7 @@
+        $(LDEXPL_LIBM) \
+        $(LIBICONV) \
+        $(LIBINTL) \
++       $(LIB_CRYPTO) \
+        $(ROUND_LIBM) \
+        $(ROUNDL_LIBM) \
+        $(SQRT_LIBM) \