dev-ml/lablgtk: Remove USE="opengl"
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 20:05:41 +0000 (21:05 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 20:05:41 +0000 (21:05 +0100)
* Depends on EOL GtkGLArea

Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-ml/lablgtk/lablgtk-2.18.10.ebuild
dev-ml/lablgtk/lablgtk-2.18.5.ebuild
dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild

index 4cbb3b17630c0303098cf3bd94f9067c456f0c1c..ea2040f934d2d2e92879c30f86900f847932fa55 100644 (file)
@@ -10,17 +10,13 @@ SRC_URI="https://github.com/garrigue/lablgtk/archive/${PV}.tar.gz -> ${P}.tar.gz
 LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
 SLOT="2/${PV}"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples glade gnomecanvas +ocamlopt opengl sourceview spell svg"
+IUSE="debug examples glade gnomecanvas +ocamlopt sourceview spell svg"
 
 DEPEND="dev-lang/ocaml:=[ocamlopt?]
        dev-ml/camlp4:=
        x11-libs/gtk+:2
        glade? ( gnome-base/libglade )
        gnomecanvas? ( gnome-base/libgnomecanvas )
-       opengl? (
-               dev-ml/lablgl:=
-               x11-libs/gtkglarea:2
-       )
        sourceview? ( x11-libs/gtksourceview:2.0 )
        spell? ( app-text/gtkspell:2 )
        svg? ( gnome-base/librsvg:2 )"
@@ -37,7 +33,8 @@ src_configure() {
                $(use_with glade)
                --without-gnomeui
                --without-panel
-               $(use_with opengl gl)
+               # relies on EOL gtkglarea
+               --without-gl
                $(use_with spell gtkspell)
                --without-gtksourceview
                $(use_with sourceview gtksourceview2)
index 8cfdfda4cf9cb73d5d677ff3c01cc68102c976fc..bf0575dc8bd121d7766b53031072a47cf7832fdd 100644 (file)
@@ -5,7 +5,7 @@ EAPI=5
 
 inherit multilib findlib
 
-IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"
+IUSE="debug examples glade gnomecanvas sourceview +ocamlopt spell svg"
 
 DESCRIPTION="Objective CAML interface for Gtk+2"
 HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
@@ -17,8 +17,6 @@ RDEPEND=">=x11-libs/gtk+-2.10:2
        svg? ( >=gnome-base/librsvg-2.2:2 )
        glade? ( >=gnome-base/libglade-2.0.1 )
        gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
-       opengl? ( >=dev-ml/lablgl-0.98:=
-               >=x11-libs/gtkglarea-1.9:2 )
        spell? ( app-text/gtkspell:2 )
        sourceview? ( x11-libs/gtksourceview:2.0 )
        dev-ml/camlp4:=
@@ -35,7 +33,7 @@ src_configure() {
                $(use_with glade) \
                --without-gnomeui \
                --without-panel \
-               $(use_with opengl gl) \
+               --without-gl \
                $(use_with spell gtkspell) \
                --without-gtksourceview \
                $(use_with sourceview gtksourceview2) \
@@ -58,7 +56,6 @@ install_examples() {
        use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
        use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
        use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
-       use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
 
        docompress -x /usr/share/doc/${PF}/examples
 }
index d1e17c9dd1b296877d01b643ae9408db80abbd4c..92dd9af9dc698d1f80b22d2f34139186e8d1dc9d 100644 (file)
@@ -10,17 +10,13 @@ SRC_URI="https://github.com/garrigue/lablgtk/releases/download/lablgtk2188/${P}.
 LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
 SLOT="2/${PV}"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples glade gnomecanvas +ocamlopt opengl sourceview spell svg"
+IUSE="debug examples glade gnomecanvas +ocamlopt sourceview spell svg"
 
 DEPEND="dev-lang/ocaml:=[ocamlopt?]
        dev-ml/camlp4:=
        x11-libs/gtk+:2
        glade? ( gnome-base/libglade )
        gnomecanvas? ( gnome-base/libgnomecanvas )
-       opengl? (
-               dev-ml/lablgl:=
-               x11-libs/gtkglarea:2
-       )
        sourceview? ( x11-libs/gtksourceview:2.0 )
        spell? ( app-text/gtkspell:2 )
        svg? ( gnome-base/librsvg:2 )"
@@ -37,7 +33,8 @@ src_configure() {
                $(use_with glade)
                --without-gnomeui
                --without-panel
-               $(use_with opengl gl)
+               # relies on EOL gtkglarea
+               --without-gl
                $(use_with spell gtkspell)
                --without-gtksourceview
                $(use_with sourceview gtksourceview2)