www-apache/mod_h2: 1.15.1 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 28 May 2019 15:36:43 +0000 (11:36 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 28 May 2019 15:37:45 +0000 (11:37 -0400)
Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: Craig Andrews <candrews@gentoo.org>
www-apache/mod_h2/Manifest
www-apache/mod_h2/mod_h2-1.15.1.ebuild [new file with mode: 0644]

index b3f5032a9add5e97c00356fe17727a5d568cb655..f95f5f991ecd861ece0417921bfce368fdce1e6c 100644 (file)
@@ -7,3 +7,4 @@ DIST mod_http2-1.13.1.tar.gz 1031498 BLAKE2B 53716d7973e5996d48a85cc96c2634d40d6
 DIST mod_http2-1.14.0.tar.gz 1034167 BLAKE2B f29d3937339562f0b8e21ab5eeaca8ff1cab26ce15c692fceffe8e6a1609a49ff6f7488cae4cc30b4fe0e97fe787e077ff771906d7d897afc5b47cc347d74b8f SHA512 dba17eb48af5c22dca3fcd75b4ecd5838dff72c9829bcf9475d8edabb0d2ce4ed2f55249ab1051c1a37e9f2f5a5a7f08f5aa47170f9c39c3b9c404c4ec6547ac
 DIST mod_http2-1.14.1.tar.gz 1032989 BLAKE2B 15359369f8332d9f9d35cb43468b2cd0d98529155d360176c41ac38c24a94824510b518aaa367cff10672bfdd3c7a24269cca4552d993bf7d63f28f857a1ae78 SHA512 04298f0fd9379ae22ba87f5dc95791091ff95cc90c2e898334cc33a0c5115905ec6cbc93676b3a28786436f351c8971721b2786e70cd498fd73ec64b5f46e611
 DIST mod_http2-1.15.0.tar.gz 1036567 BLAKE2B 1ed9fdd7bf13c8ec7ac14b2cd0a109f0cd6e6d1eb8047e1cf6cd107143e23ebb6d9f9ef753942d44ec4d2168e0783dd23dd66b338d8631c504d4cd81b0287b83 SHA512 c3541c930ceee81dfbd688ea155561b6e06aa8ef486830a95e6cfa621f3589aa9c9e15661a4b81463cbe716d02dd28a574e3a74894a74d7c751c88894d378858
+DIST mod_http2-1.15.1.tar.gz 1026120 BLAKE2B 724d09bfafc2fe6a288eeebd7fbdcbe2c3d3e146b0afae42ae72be16931904982b07fd55f4c96da6f8718b5058421813ecd186ac4b4161a74ea7b83c38394ed1 SHA512 3564e8e4cb896420b91669d710d70cdecbe45480078c790960fd7d8c788ac9b843517c2af0747932ad53eb048c39765c4ceb2b7de7e04a1bc7fcb57af0117eb9
diff --git a/www-apache/mod_h2/mod_h2-1.15.1.ebuild b/www-apache/mod_h2/mod_h2-1.15.1.ebuild
new file mode 100644 (file)
index 0000000..3e6d435
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+       inherit git-r3
+else
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+       >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_compile() {
+       default
+}
+
+src_install() {
+       default
+
+       APACHE2_MOD_DEFINE="HTTP2"
+       insinto "${APACHE_MODULES_CONFDIR}"
+       newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}