dev-go/go-tools: filter GOCACHE vars (bug 678964)
authorZac Medico <zmedico@gentoo.org>
Sat, 16 Mar 2019 20:44:48 +0000 (13:44 -0700)
committerZac Medico <zmedico@gentoo.org>
Sat, 16 Mar 2019 21:42:57 +0000 (14:42 -0700)
Reported-by: Toralf Förster <toralf@gentoo.org>
Closes: https://bugs.gentoo.org/678964
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-go/go-tools/go-tools-0_pre20180817.ebuild
dev-go/go-tools/go-tools-9999.ebuild

index 5191bd7e69ca1cf6070c318326c693a5882657a8..a7bd294e620376f7e96c9c4d53d0852951de9666 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -47,6 +47,7 @@ src_prepare() {
 }
 
 src_compile() {
+       export -n GOCACHE XDG_CACHE_HOME #678964
        # Generate static.go with favicon included
        pushd src/golang.org/x/tools/godoc/static >/dev/null || die
        GOPATH="${S}:$(get_golibdir_gopath)" \
index fb8bd018f99dd249de3c42f813e5e7245b2540e6..ffc68729ed0bcf84915c96d013c7d04e2a311e8b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -65,6 +65,7 @@ src_prepare() {
 }
 
 src_compile() {
+       export -n GOCACHE XDG_CACHE_HOME #678964
        # Generate static.go with favicon included
        pushd src/golang.org/x/tools/godoc/static >/dev/null || die
        GOPATH="${S}" GOBIN="${S}/bin" \