sci-visualization/veusz: bump to 3.1
authorAndrey Grozin <grozin@gentoo.org>
Sun, 10 Nov 2019 10:31:49 +0000 (17:31 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 10 Nov 2019 10:32:43 +0000 (17:32 +0700)
Suggested-by: Torokhov Sergey <torokhov-s-a@yandex.ru>
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
sci-visualization/veusz/Manifest
sci-visualization/veusz/veusz-3.1.ebuild [new file with mode: 0644]

index 255f56aa435f155cb49e0ea1f1e073f89ba65bc0..b31b125897d88da2f401ec6b024b4f3bb0938587 100644 (file)
@@ -1,2 +1,3 @@
 DIST veusz-3.0.1.tar.gz 2554401 BLAKE2B 6e5649eef94ce0bd7fcdfa8325b35de144aaecd792f32c149f5a6f16c7c35f10d29bebeb37531d726e1b87f6d46855d7cdb2af402ec8fd0a2c1af91844d12c03 SHA512 99766c0fee70c12bba7b2ee8434224649763323aa9278d2116159f18257e1e1c5a491d591efb779c1bbb9dba1fb524ad8185fa2e91429ba1cc594fd632cb6238
 DIST veusz-3.0.tar.gz 2550683 BLAKE2B 72f0da8d9b993d8a3252fbb93314a53832fbf319287946e9ebc9317ebdab3f10ef2071012b88a1ff3d31d4732f367ded0b217dfa9766f5a09abe90e96b769e45 SHA512 a740d5677e8f23245e54573de0faaa66b659b54e289b256dc344f5aa0cc2a05db26efce57ff31b19c1235e04a9aa22cfa12125a784d27b0e3725277cbfae1b06
+DIST veusz-3.1.tar.gz 2524607 BLAKE2B ca5c5a75e02c9461e1d81dc4d2cc09865ebd4424f072616bf0a231a1f592a5c1c5aad93f713ed9ec1d9e2ad39b877a36c236b615d904295608d7990eaf59d5fb SHA512 9b940d1cc224f4729f788abe1e29352d35e69d2f78bae7f072a783d339198a8171b0f0b0a5f5af82ef0f0693550a42409956a9cc3888aa46d110d777e81941a4
diff --git a/sci-visualization/veusz/veusz-3.1.ebuild b/sci-visualization/veusz/veusz-3.1.ebuild
new file mode 100644 (file)
index 0000000..4eddb89
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit desktop distutils-r1 virtualx xdg
+
+DESCRIPTION="Qt scientific plotting package with good Postscript output"
+HOMEPAGE="https://veusz.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus doc emf fits hdf5 minuit"
+
+CDEPEND="dev-python/PyQt5[widgets,svg,printsupport,${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+       emf? ( dev-python/pyemf[$(python_gen_usedep 'python2*')] )
+       fits? ( dev-python/astropy[${PYTHON_USEDEP}] )
+       hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+       minuit? ( || ( dev-python/iminuit[${PYTHON_USEDEP}] dev-python/pyminuit[${PYTHON_USEDEP}] ) )"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/sip[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+       distutils-r1_src_prepare
+       xdg_environment_reset
+}
+
+python_test() {
+       distutils_install_for_testing
+       VIRTUALX_COMMAND="${EPYTHON}" \
+               VEUSZ_RESOURCE_DIR="${S}" \
+               virtx tests/runselftest.py
+}
+
+python_install() {
+       distutils-r1_python_install
+       # symlink the license, bug #341653
+       rm "${D}/$(python_get_sitedir)"/${PN}/{COPYING,AUTHORS,ChangeLog} || die
+       mkdir -p "${D}/$(python_get_sitedir)" || die
+       cat >> "${D}/$(python_get_sitedir)"/${PN}/COPYING <<- EOF
+       Please visit
+
+       https://www.gnu.org/licenses/gpl-2.0.html
+
+       for the full license text.
+       EOF
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       if use doc; then
+               dodoc Documents/manual/pdf/${PN}.pdf
+               docinto html
+               dodoc -r Documents/manual/html
+       fi
+
+       doicon icons/veusz.png
+       domenu "${FILESDIR}"/veusz.desktop
+       insinto /usr/share/mime/packages
+       doins "${FILESDIR}"/veusz.xml
+}