app-forensics/ovaldi: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 09:50:56 +0000 (10:50 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 10:15:21 +0000 (11:15 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
app-forensics/ovaldi/Manifest
app-forensics/ovaldi/files/disable-acl.patch [deleted file]
app-forensics/ovaldi/files/ovaldi-5.10.1.4-disable-selinux-probes.patch [deleted file]
app-forensics/ovaldi/files/ovaldi-5.10.1.4-strnicmp.patch [deleted file]
app-forensics/ovaldi/files/ovaldi-5.10.1.4-xerces3.patch [deleted file]
app-forensics/ovaldi/ovaldi-5.10.1.4.ebuild [deleted file]

index 91d5ee64560973f23ed4423ebee9a601e107a828..10d46d80f07b1d1ef30f134d2b706eff3e55514d 100644 (file)
@@ -1,2 +1 @@
-DIST ovaldi-5.10.1.4-src.tar.bz2 14868251 BLAKE2B a85d4d1b80226dd4059d206b471788b1417224dea54ba0b5813dda3427543195b9fb5505e4f9d5db4655acb36385a84ff23556c281189558bf1a637f5a122262 SHA512 d7926a7416fe90013e203b333390e33d51c3eb0caa6ebba69dd593791a8377ac38f5db72fcff2d1ab2dd39a0f5d1b0d2a0d08f906d3e26740288532a27debb47
 DIST ovaldi-5.10.1.7-src.tar.bz2 20391784 BLAKE2B 7e2c719f0819f967c6aee533bb881c29ffac756461460d73e3231f1cffd254d88a26e716f0334d023daa7fa6f9c314bf7a42b6c13e2a90daa558e589d135479c SHA512 22c373436889b03ffb5d479bd322703bbd8b5b335f116a3b38a3d206ddaaf3115961ab89597c3907b6e5d745eb302a042c135c73cde0eaae10e51f5d6e3e55ec
diff --git a/app-forensics/ovaldi/files/disable-acl.patch b/app-forensics/ovaldi/files/disable-acl.patch
deleted file mode 100644 (file)
index 49ea42c..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/probes/unix/FileProbe.cpp.old  2013-01-14 16:28:33.000000000 +0100
-+++ src/probes/unix/FileProbe.cpp      2013-01-14 16:30:33.000000000 +0100
-@@ -427,19 +427,8 @@
-          5) If a file doesn't have an ACL, or it matches the standard UNIX permissions, the value will be 'false' (this is covered by acl_extended_file() - thank you openscap)\r
-          6) If a file has an ACL, the value will be 'true'.\r
-       */\r
--      \r
--      int hasExtendedAcl = acl_extended_file(filePath.c_str());\r
--      if(hasExtendedAcl > -1){ // behavior 4, 5, and 6\r
--          item->AppendElement(new ItemEntity("has_extended_acl",Common::ToString(hasExtendedAcl),OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_EXISTS,0));\r
--      }else{\r
--        if(errno == EOPNOTSUPP){ // behavior 3\r
--          item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_DOES_NOT_EXIST,0));\r
--          }else{ // behavior 2\r
--          item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_ERROR,0));\r
--            item->AppendMessage(new OvalMessage(string("Error reading ACL data: ") + strerror(errno)));\r
--          }\r
--      }\r
\r
-+      item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_NOT_COLLECTED,0));\r
- # else\r
-       // behavior 1\r
-       item->AppendElement(new ItemEntity("has_extended_acl","",OvalEnum::DATATYPE_BOOLEAN,OvalEnum::STATUS_NOT_COLLECTED,0));\r
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.4-disable-selinux-probes.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.4-disable-selinux-probes.patch
deleted file mode 100644 (file)
index b9d02d7..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/probes/unix/Process58Probe.cpp.old     2013-01-14 16:05:18.000000000 +0100
-+++ src/probes/unix/Process58Probe.cpp 2013-01-14 16:06:16.000000000 +0100
-@@ -29,8 +29,8 @@
- //****************************************************************************************//\r
\r
- #ifdef LINUX\r
--#  include <selinux/selinux.h>\r
--#  include <selinux/context.h>\r
-+/*#  include <selinux/selinux.h>\r
-+#  include <selinux/context.h>*/\r
- #  include <sys/capability.h>\r
- #  include <SecurityContextGuard.h>\r
- #endif\r
-@@ -328,7 +328,7 @@
-       pid_t sessionId;\r
-       uid_t loginuid;\r
-       uint64_t effCap, *effCapp=&effCap;\r
--      string selinuxDomainLabel;\r
-+/*    string selinuxDomainLabel;*/\r
\r
-       Process58Probe::ProcStatus statStatus, statusStatus, ttyStatus, loginuidStatus;\r
\r
-@@ -423,10 +423,10 @@
-       }\r
\r
-       // this one doesn't require reading anything in /proc\r
--      if (!RetrieveSelinuxDomainLabel(pid, &selinuxDomainLabel, &errMsg)) {\r
-+/*    if (!RetrieveSelinuxDomainLabel(pid, &selinuxDomainLabel, &errMsg)) {\r
-               item->AppendMessage(new OvalMessage(errMsg, OvalEnum::LEVEL_ERROR));\r
-               item->SetStatus(OvalEnum::STATUS_ERROR);\r
--      }\r
-+      }*/\r
\r
-       // The Linux start time is represented as the number of jiffies (1/100 sec)\r
-       // that the application was started after the last system reboot.  To get an\r
-@@ -522,10 +522,10 @@
-               // aren't any.\r
-               item->AppendElement(new ItemEntity("posix_capability", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_ERROR));\r
\r
--      if (selinuxDomainLabel.empty())\r
-+/*    if (selinuxDomainLabel.empty())\r
-               item->AppendElement(new ItemEntity("selinux_domain_label", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_ERROR));\r
-       else\r
--              item->AppendElement(new ItemEntity("selinux_domain_label", selinuxDomainLabel));\r
-+              item->AppendElement(new ItemEntity("selinux_domain_label", selinuxDomainLabel));*/\r
\r
-       if (statStatus == PROC_OK)\r
-               item->AppendElement(new ItemEntity("session_id", Common::ToString(sessionId), OvalEnum::DATATYPE_INTEGER));\r
-@@ -740,7 +740,7 @@
-                                                                                          capMap[capEnum]));\r
-       }\r
- }\r
--\r
-+/*\r
- bool Process58Probe::RetrieveSelinuxDomainLabel(pid_t pid, string *label, string *err) {\r
-       security_context_t sctx;\r
-       int ec = getpidcon(pid, &sctx);\r
-@@ -763,7 +763,7 @@
-       *label = tmp;\r
-       return true;\r
- }\r
--\r
-+*/\r
- #elif defined SUNOS\r
\r
- void Process58Probe::GetPSInfo(string command, string pidStr, ItemVector* items) {\r
-@@ -830,7 +830,7 @@
-       item->AppendElement(new ItemEntity("exec_shield", "", OvalEnum::DATATYPE_BOOLEAN, OvalEnum::STATUS_NOT_COLLECTED));\r
-       item->AppendElement(new ItemEntity("loginuid", "", OvalEnum::DATATYPE_INTEGER, OvalEnum::STATUS_NOT_COLLECTED));\r
-       item->AppendElement(new ItemEntity("posix_capability", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));\r
--      item->AppendElement(new ItemEntity("selinux_domain_label", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));\r
-+/*    item->AppendElement(new ItemEntity("selinux_domain_label", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));*/\r
-       item->AppendElement(new ItemEntity("session_id", Common::ToString(info.pr_sid), OvalEnum::DATATYPE_INTEGER));\r
\r
-       items->push_back(item);\r
-@@ -988,7 +988,7 @@
-       item->AppendElement(new ItemEntity("exec_shield", "", OvalEnum::DATATYPE_BOOLEAN, OvalEnum::STATUS_NOT_COLLECTED));\r
-       item->AppendElement(new ItemEntity("loginuid", "", OvalEnum::DATATYPE_INTEGER, OvalEnum::STATUS_NOT_COLLECTED));\r
-       item->AppendElement(new ItemEntity("posix_capability", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));\r
--      item->AppendElement(new ItemEntity("selinux_domain_label", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));\r
-+/*    item->AppendElement(new ItemEntity("selinux_domain_label", "", OvalEnum::DATATYPE_STRING, OvalEnum::STATUS_NOT_COLLECTED));*/\r
-       item->AppendElement(new ItemEntity("session_id", "", OvalEnum::DATATYPE_INTEGER, OvalEnum::STATUS_NOT_COLLECTED));\r
-     \r
-     items->push_back(item);\r
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.4-strnicmp.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.4-strnicmp.patch
deleted file mode 100644 (file)
index fc127ef..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Main.h.old     2010-10-22 14:59:13.000000000 +0200
-+++ src/Main.h 2010-10-22 14:59:38.000000000 +0200
-@@ -38,7 +38,7 @@
- #endif\r
\r
- #ifdef LINUX\r
--#  define STRNICMP strnicmp\r
-+#  define STRNICMP strncasecmp\r
- #elif defined SUNOS\r
- #  define STRNICMP strncasecmp\r
- #elif defined DARWIN\r
diff --git a/app-forensics/ovaldi/files/ovaldi-5.10.1.4-xerces3.patch b/app-forensics/ovaldi/files/ovaldi-5.10.1.4-xerces3.patch
deleted file mode 100644 (file)
index 9350029..0000000
+++ /dev/null
@@ -1,283 +0,0 @@
---- src/XmlProcessor.h.old     2011-08-18 14:35:41.608703233 +0200
-+++ src/XmlProcessor.h 2011-08-18 14:39:21.835597094 +0200
-@@ -38,14 +38,17 @@
- #include <string>\r
\r
- //    required xerces includes\r
--#include <xercesc/dom/DOMBuilder.hpp>\r
- #include <xercesc/dom/DOMDocument.hpp>\r
- #include <xercesc/dom/DOMErrorHandler.hpp>\r
- #include <xercesc/dom/DOMError.hpp>\r
\r
- // for entity resolver\r
--#include <xercesc/dom/DOMEntityResolver.hpp>\r
--#include <xercesc/dom/DOMInputSource.hpp>\r
-+\r
-+#include <xercesc/dom/DOMImplementationRegistry.hpp>\r
-+#include <xercesc/dom/DOMLSParser.hpp>\r
-+#include <xercesc/sax/EntityResolver.hpp>\r
-+#include <xercesc/sax/InputSource.hpp>\r
-+#include <xercesc/sax2/SAX2XMLReader.hpp>\r
\r
- #include "Exception.h"\r
\r
-@@ -53,12 +56,14 @@
-       This class extends the default DOMEntityResolver and implments the resolve entity method \r
-       to support \r
- */\r
--class DataDirResolver : public xercesc::DOMEntityResolver {\r
-+class DataDirResolver : public xercesc::EntityResolver {\r
- public:\r
-       /**\r
-      *     \r
-       */\r
--      xercesc::DOMInputSource *resolveEntity (const XMLCh *const publicId, const XMLCh *const systemId, const XMLCh *const baseURI);\r
-+//    xercesc::DOMInputSource *resolveEntity (const XMLCh *const publicId, const XMLCh *const systemId, const XMLCh *const baseURI);
-+      xercesc::InputSource *resolveEntity (const XMLCh *const publicId, const XMLCh *const systemId);
-+      xercesc::DOMLSInput *resolveEntity (const XMLCh *const publicId, const XMLCh *const systemId, const XMLCh *const baseURI);
- };\r
\r
- /**\r
-@@ -144,7 +149,7 @@
-        * owns the documents it builds.  Users must manually destroy\r
-        * those documents.\r
-        */\r
--      xercesc::DOMBuilder *parserWithCallerAdoption;\r
-+      xercesc::DOMLSParser *parserWithCallerAdoption;\r
\r
-       /**\r
-        * This parser doesn't have user-adoption switched on, so it\r
-@@ -156,7 +161,7 @@
-        * appear to ever be switched off.  So to make sure this isn't\r
-        * leaking memory, I have created separate parsers.\r
-        */\r
--      xercesc::DOMBuilder *parser;\r
-+      xercesc::DOMLSParser *parser;\r
\r
-       /** The entity resolver for both parsers. */\r
-       DataDirResolver resolver;\r
---- src/probes/independent/XmlFileContentProbe.cpp.old 2010-10-22 14:49:22.000000000 +0200
-+++ src/probes/independent/XmlFileContentProbe.cpp     2010-10-22 14:51:39.000000000 +0200
-@@ -419,12 +419,24 @@
-     return new DummyEntityResolver::DoNothingBinInputStream();\r
- }\r
\r
-+#if XERCES_VERSION_MAJOR < 3\r
- unsigned int DummyEntityResolver::DoNothingBinInputStream::curPos() const\r
-+#else\r
-+const XMLCh* DummyEntityResolver::DoNothingBinInputStream::getContentType() const\r
-+{\r
-+    return NULL;\r
-+}\r
-+XMLFilePos DummyEntityResolver::DoNothingBinInputStream::curPos() const\r
-+#endif\r
- {\r
-     return 0;\r
- }\r
\r
-+#if XERCES_VERSION_MAJOR < 3\r
- unsigned int DummyEntityResolver::DoNothingBinInputStream::readBytes(XMLByte *const /*toFill*/, const unsigned int /*maxToRead*/)\r
-+#else\r
-+XMLSize_t DummyEntityResolver::DoNothingBinInputStream::readBytes(XMLByte *const toFill, XMLSize_t maxToRead)\r
-+#endif\r
- {\r
-     return 0;\r
- }\r
---- src/probes/independent/XmlFileContentProbe.h.old   2010-10-22 14:55:47.000000000 +0200
-+++ src/probes/independent/XmlFileContentProbe.h       2010-10-22 14:57:00.000000000 +0200
-@@ -134,8 +134,14 @@
-     class DoNothingBinInputStream : public BinInputStream\r
-     {\r
-     public:\r
-+#if XERCES_VERSION_MAJOR < 3\r
-         virtual unsigned int curPos() const;\r
-         virtual unsigned int readBytes(XMLByte *const toFill, const unsigned int maxToRead);\r
-+#else\r
-+      virtual XMLFilePos curPos() const;\r
-+      virtual const XMLCh* getContentType() const;\r
-+      virtual XMLSize_t readBytes(XMLByte *const toFill, XMLSize_t maxToRead);\r
-+#endif\r
-     };\r
- };\r
\r
---- src/XmlCommon.cpp.old
-+++ src/XmlCommon.cpp
-@@ -546,7 +546,11 @@ void XmlCommon::AddSchemaLocation(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *do
- string XmlCommon::GetNamespace(DOMElement *element) {\r
\r
-       string xmlns = "";\r
-+#if XERCES_VERSION_MAJOR < 3\r
-       xmlns = XmlCommon::ToString(element->getTypeInfo()->getNamespace());\r
-+#else\r
-+      xmlns = XmlCommon::ToString(element->getSchemaTypeInfo()->getTypeNamespace());\r
-+#endif\r
-       if (xmlns.compare("") == 0) {\r
-               xmlns = "";\r
-       }\r
---- src/XmlProcessor.cpp.old   2013-01-14 15:16:14.000000000 +0100
-+++ src/XmlProcessor.cpp       2013-01-14 15:19:20.000000000 +0100
-@@ -35,7 +35,6 @@
- // for dom Writer\r
- #include <xercesc/dom/DOMImplementation.hpp>\r
- #include <xercesc/dom/DOMImplementationLS.hpp>\r
--#include <xercesc/dom/DOMWriter.hpp>\r
- #include <xercesc/framework/StdOutFormatTarget.hpp>\r
- #include <xercesc/framework/LocalFileFormatTarget.hpp>\r
- #include <xercesc/util/XMLUni.hpp>\r
-@@ -50,11 +49,26 @@
- using namespace std;\r
- using namespace xercesc;\r
\r
-+#if XERCES_VERSION_MAJOR < 3\r
-+#define SetParameter(serializer,n,v) if (serializer->canSetFeature(n,v)) serializer->setFeature(n,v)\r
-+#else\r
-+#define SetParameter(serializer,n,v) if (serializer->getDomConfig()->canSetParameter(n,v)) serializer->getDomConfig()->setParameter(n,v)\r
-+#endif\r
-+\r
- //****************************************************************************************//\r
- //                    DataDirResolver Class                                                                             //    \r
- //****************************************************************************************//\r
--\r
-+#if XERCES_VERSION_MAJOR < 3\r
- DOMInputSource* DataDirResolver::resolveEntity (const XMLCh *const /*publicId*/, const XMLCh *const systemId, const XMLCh *const /*baseURI*/) {\r
-+#else\r
-+InputSource* DataDirResolver::resolveEntity(const XMLCh* publicId, const XMLCh* systemId)\r
-+{\r
-+      return NULL;\r
-+      //return DataDirResolver::resolveEntity (publicId, systemId, NULL);\r
-+}\r
-+\r
-+DOMLSInput* DataDirResolver::resolveEntity (const XMLCh *const publicId, const XMLCh *const systemId, const XMLCh *const baseURI) {\r
-+#endif\r
-       string path = "";\r
-       size_t last;\r
-       string schemapath = Common::GetSchemaPath();\r
-@@ -127,7 +141,7 @@
-               parserWithCallerAdoption = makeParser(schemaLocation);\r
-               // add one extra feature on this parser to prevent it from\r
-               // taking ownership of its documents.\r
--              parserWithCallerAdoption->setFeature(XMLUni::fgXercesUserAdoptsDOMDocument, true);\r
-+              SetParameter(parserWithCallerAdoption, XMLUni::fgXercesUserAdoptsDOMDocument, true);\r
\r
-     } catch (const XMLException& toCatch) {\r
-         string errMsg = "Error:  An error occured durring initialization of the xml utilities:\n";\r
-@@ -156,32 +170,40 @@
-       XMLPlatformUtils::Terminate();\r
- }\r
\r
--DOMBuilder *XmlProcessor::makeParser(const string &schemaLocation) {\r
-+DOMLSParser *XmlProcessor::makeParser(const string &schemaLocation) {\r
-     // Instantiate the DOM parser.\r
-       static const XMLCh gLS[] = { chLatin_L, chLatin_S, chNull };\r
-       DOMImplementation *impl = DOMImplementationRegistry::getDOMImplementation(gLS);\r
\r
--      DOMBuilder *parser = ((DOMImplementationLS*)impl)->createDOMBuilder(DOMImplementationLS::MODE_SYNCHRONOUS, 0);\r
-+#if XERCES_VERSION_MAJOR < 3\r
-+      DOMLSParser *parser = ((DOMImplementationLS*)impl)->createDOMLSParser(DOMImplementationLS::MODE_SYNCHRONOUS, 0);\r
-+#else\r
-+      DOMLSParser *parser = ((DOMImplementationLS*)impl)->createLSParser(DOMImplementationLS::MODE_SYNCHRONOUS, 0);\r
-+#endif\r
\r
-       ///////////////////////////////////////////////////////\r
-       //      Set features on the builder\r
-       ///////////////////////////////////////////////////////\r
\r
--      parser->setFeature(XMLUni::fgDOMComments, false); // Discard Comment nodes in the document. \r
--      parser->setFeature(XMLUni::fgDOMDatatypeNormalization, true); // Let the validation process do its datatype normalization that is defined in the used schema language.  \r
--      parser->setFeature(XMLUni::fgDOMNamespaces, true); //  Perform Namespace processing\r
--      parser->setFeature(XMLUni::fgDOMValidation, true); // Report all validation errors.  \r
--      parser->setFeature(XMLUni::fgXercesSchema, true); //  Enable the parser's schema support.\r
--      parser->setFeature(XMLUni::fgXercesSchemaFullChecking, true); //  Enable full schema constraint checking, including checking which may be time-consuming or memory intensive. Currently, particle unique attribution constraint checking and particle derivation restriction checking are controlled by this option.  \r
--      parser->setFeature(XMLUni::fgXercesValidationErrorAsFatal, true); //  The parser will treat validation error as fatal and will exit  \r
--      parser->setFeature(XMLUni::fgXercesDOMHasPSVIInfo, true); // Enable storing of PSVI information in element and attribute nodes.\r
-+      SetParameter(parser, XMLUni::fgDOMComments, false); // Discard Comment nodes in the document. \r
-+      SetParameter(parser, XMLUni::fgDOMDatatypeNormalization, true); // Let the validation process do its datatype normalization that is defined in the used schema language.  \r
-+      SetParameter(parser, XMLUni::fgDOMNamespaces, true); //  Perform Namespace processing\r
-+      SetParameter(parser, XMLUni::fgDOMValidate, true); // Report all validation errors.  \r
-+      SetParameter(parser, XMLUni::fgXercesSchema, true); //  Enable the parser's schema support.\r
-+      SetParameter(parser, XMLUni::fgXercesSchemaFullChecking, true); //  Enable full schema constraint checking, including checking which may be time-consuming or memory intensive. Currently, particle unique attribution constraint checking and particle derivation restriction checking are controlled by this option.  \r
-+      SetParameter(parser, XMLUni::fgXercesValidationErrorAsFatal, true); //  The parser will treat validation error as fatal and will exit  \r
-+      SetParameter(parser, XMLUni::fgXercesDOMHasPSVIInfo, true); // Enable storing of PSVI information in element and attribute nodes.\r
\r
-       ///////////////////////////////////////////////////////\r
- //****************************************************************************************//\r
- //                    The following code was added to handle air-gap operation                                          //    \r
- //****************************************************************************************//\r
-       /* Look for XML schemas in local directory instead of Internet */\r
-+#if XERCES_VERSION_MAJOR < 3\r
-       parser->setEntityResolver (&resolver);\r
-+#else\r
-+      parser->getDomConfig()->setParameter(XMLUni::fgXercesEntityResolver, &resolver);\r
-+#endif\r
- //****************************************************************************************//\r
- //                    End of air-gap code                                                                                                                       //    \r
- //****************************************************************************************//\r
-@@ -189,7 +211,11 @@
-       ///////////////////////////////////////////////////////\r
-       //      Add an Error Handler\r
-       ///////////////////////////////////////////////////////\r
-+#if XERCES_VERSION_MAJOR < 3\r
-       parser->setErrorHandler(&errHandler);\r
-+#else\r
-+      parser->getDomConfig()->setParameter(XMLUni::fgDOMErrorHandler, &errHandler);\r
-+#endif\r
\r
-       // Fix a schema location if possible, so instance documents don't\r
-       // have to set the schemaLocation attribute.  And if they do, this\r
-@@ -197,7 +223,7 @@
-       // overriding of the value in instance documents.\r
-       if (!schemaLocation.empty()) {\r
-               XMLCh *schemaLocationCstr = XMLString::transcode(schemaLocation.c_str());\r
--              parser->setProperty(XMLUni::fgXercesSchemaExternalSchemaLocation, schemaLocationCstr);\r
-+              SetParameter(parser, XMLUni::fgXercesSchemaExternalSchemaLocation, schemaLocationCstr);\r
-               XMLString::release(&schemaLocationCstr);\r
-       }\r
\r
-@@ -279,23 +305,19 @@
-               XMLCh tempStr[100];\r
-               XMLString::transcode("LS", tempStr, 99);\r
-               DOMImplementation *impl = DOMImplementationRegistry::getDOMImplementation(tempStr);\r
-+#if XERCES_VERSION_MAJOR < 3\r
-               DOMWriter *theSerializer = ((DOMImplementationLS*)impl)->createDOMWriter();\r
-+#else\r
-+              DOMLSSerializer *theSerializer = ((DOMImplementationLS*)impl)->createLSSerializer();\r
-+#endif\r
\r
--              // set feature if the serializer supports the feature/mode\r
--              if (theSerializer->canSetFeature(XMLUni::fgDOMWRTSplitCdataSections, true))\r
--                      theSerializer->setFeature(XMLUni::fgDOMWRTSplitCdataSections, true);\r
\r
--              if (theSerializer->canSetFeature(XMLUni::fgDOMWRTDiscardDefaultContent, true))\r
--                      theSerializer->setFeature(XMLUni::fgDOMWRTDiscardDefaultContent, true);\r
--\r
--              if (theSerializer->canSetFeature(XMLUni::fgDOMWRTFormatPrettyPrint, true))\r
--                      theSerializer->setFeature(XMLUni::fgDOMWRTFormatPrettyPrint, true);\r
--\r
--              if (theSerializer->canSetFeature(XMLUni::fgDOMWRTBOM, false))\r
--                      theSerializer->setFeature(XMLUni::fgDOMWRTBOM, false);\r
--\r
--              //if (theSerializer->canSetFeature(XMLUni::fgDOMWRTDiscardDefaultContent, true))\r
--              //      theSerializer->setFeature(XMLUni::fgDOMWRTBOM, true);\r
-+              // set feature if the serializer supports the feature/mode\r
-+              SetParameter(theSerializer, XMLUni::fgDOMWRTSplitCdataSections, true);\r
-+              SetParameter(theSerializer, XMLUni::fgDOMWRTDiscardDefaultContent, true);\r
-+              SetParameter(theSerializer, XMLUni::fgDOMWRTFormatPrettyPrint, true);\r
-+              SetParameter(theSerializer, XMLUni::fgDOMWRTBOM, false);\r
-+              //SetParameter(theSerializer, XMLUni::fgDOMWRTBOM, true);\r
\r
-               //\r
-               // Plug in a format target to receive the resultant\r
-@@ -313,7 +335,13 @@
-               //\r
-               // do the serialization through DOMWriter::writeNode();\r
-               //\r
-+#if XERCES_VERSION_MAJOR < 3\r
-               theSerializer->writeNode(myFormTarget, *doc);\r
-+#else\r
-+              DOMLSOutput *output = ((DOMImplementationLS*)impl)->createLSOutput();\r
-+              output->setByteStream(myFormTarget);\r
-+              theSerializer->write(doc, output);\r
-+#endif\r
\r
-               theSerializer->release();\r
-               delete myFormTarget;\r
diff --git a/app-forensics/ovaldi/ovaldi-5.10.1.4.ebuild b/app-forensics/ovaldi/ovaldi-5.10.1.4.ebuild
deleted file mode 100644 (file)
index c23af38..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Free implementation of OVAL"
-HOMEPAGE="http://oval.mitre.org/language/interpreter.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="acl ldap selinux"
-
-CDEPEND="dev-libs/libgcrypt:0
-       dev-libs/libpcre
-       dev-libs/xalan-c
-       dev-libs/xerces-c
-       sys-apps/util-linux
-       sys-libs/libcap
-       acl? ( sys-apps/acl )
-       ldap? ( net-nds/openldap )"
-DEPEND="${CDEPEND}
-       sys-apps/sed"
-RDEPEND="${CDEPEND}
-       selinux? ( sys-libs/libselinux )"
-
-S="${WORKDIR}/${P}-src"
-
-src_prepare() {
-       #Ovaldi do not support xerces 3, but portage have only that
-       epatch "${FILESDIR}"/${P}-xerces3.patch
-       sed -i 's,xercesc::DOMBuilder,xercesc::DOMLSParser,' src/XmlProcessor.h || die
-       sed -i 's,DOMBuilder,DOMLSParser,' src/XmlProcessor.cpp || die
-
-       epatch "${FILESDIR}"/${P}-strnicmp.patch
-
-       if ! use ldap ; then
-               einfo "Disabling LDAP probes"
-               sed -i 's,.*ldap,//&,' src/linux/ProbeFactory.cpp || die
-               sed -i 's,.*LDAP,//&,' src/linux/ProbeFactory.cpp || die
-               sed -i 's/-lldap//' project/linux/Makefile || die
-               sed -i 's/-llber//' project/linux/Makefile || die
-               sed -i 's/.*LDAPProbe.h.*//' src/linux/ProbeFactory.h || die
-               rm src/probes/independent/LDAPProbe.{cpp,h} || die
-       fi
-
-       if ! use acl ; then
-               sed -i 's,.*libacl,//&,' src/probes/unix/FileProbe.h || die
-               epatch "${FILESDIR}"/disable-acl.patch
-               sed -i 's, -lacl , ,' project/linux/Makefile || die
-       fi
-
-       einfo "Disabling rpm probes"
-       sed -i 's/^PACKAGE_RPM/#PACKAGE_RPM/' project/linux/Makefile || die
-
-       # same thing for dpkg, but package dpkg is not sufficient, needs app-arch/apt-pkg that is not on tree
-       einfo "Disabling dpkg probes"
-       sed -i 's/^PACKAGE_DPKG/#PACKAGE_DPKG/' project/linux/Makefile || die
-
-       #Disabling SELinux support
-       if ! use selinux ; then
-               rm src/probes/linux/SelinuxSecurityContextProbe.cpp || die
-               rm src/probes/linux/SelinuxBooleanProbe.cpp || die
-               rm src/probes/linux/SelinuxBooleanProbe.h || die
-               epatch "${FILESDIR}"/${P}-disable-selinux-probes.patch
-               sed -i 's,.*selinux.*,//&,' src/linux/ProbeFactory.cpp || die
-               sed -i 's,.*Selinux.*,//&,' src/linux/ProbeFactory.cpp || die
-               sed -i 's,.*selinux.*,//&,' src/linux/ProbeFactory.h || die
-               sed -i 's,.*Selinux.*,//&,' src/linux/ProbeFactory.h || die
-               sed -i 's,.*SecurityContextGuard.h.*,//&,' src/probes/unix/Process58Probe.cpp || die
-               rm src/linux/SecurityContextGuard.h || die
-               sed -i 's, -lselinux,,' project/linux/Makefile || die
-       fi
-       # respect CXXFLAGS and CXX
-       sed -i -e '/^CPPFLAGS/s/$(INCDIRS)/$(CXXFLAGS) \0/' project/linux/Makefile || die
-       tc-export CXX
-}
-
-src_compile () {
-       emake -C project/linux
-}
-
-src_install () {
-       # no make install in Makefile
-       dosbin project/linux/Release/ovaldi project/linux/ovaldi.sh
-       dodir /var/log/${PN}
-       insinto /usr/share/${PN}
-       doins xml/*
-       dodoc docs/{README.txt,version.txt}
-       doman docs/ovaldi.1
-}