dev-python/piexif: add Py3.8 support
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 10 May 2020 12:48:16 +0000 (14:48 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 10 May 2020 13:01:56 +0000 (15:01 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-python/piexif/piexif-1.1.3.ebuild

index 79d68eaa74f826baa9e9cf997e1d90a4d5f1181d..0577ea544dd2e1fe7b48ac5d10687bb57193f92c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -24,5 +24,5 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 RDEPEND=""
 
 python_test() {
-       "${PYTHON}" setup.py test
+       "${PYTHON}" setup.py test || die
 }