www-client/chromium: keep icu if compiling with libcxx
authorStephan Hartmann <stha09@googlemail.com>
Sun, 26 Apr 2020 19:19:22 +0000 (21:19 +0200)
committerMike Gilbert <floppym@gentoo.org>
Sun, 26 Apr 2020 19:23:39 +0000 (15:23 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15536

www-client/chromium/chromium-83.0.4103.23.ebuild

index 1c70eb46184de0f4f2434104ffcee531095363a1..2056dda0889a72150db0c16bb4b59a4c52360e25 100644 (file)
@@ -454,6 +454,9 @@ src_prepare() {
                keeplibs+=( third_party/openh264 )
                keeplibs+=( third_party/re2 )
                keeplibs+=( third_party/snappy )
+               if use system-icu; then
+                       keeplibs+=( third_party/icu )
+               fi
        fi
        # Remove most bundled libraries. Some are still needed.
        build/linux/unbundle/remove_bundled_libraries.py "${keeplibs[@]}" --do-remove || die