app-laptop/mbpfan: update the live ebuild
authorGöktürk Yüksek <gokturk@gentoo.org>
Sun, 2 Apr 2017 20:03:28 +0000 (16:03 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Sun, 2 Apr 2017 20:10:42 +0000 (16:10 -0400)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-laptop/mbpfan/mbpfan-9999.ebuild

index c824800ff6f827e42cf70dd5170fab75bcfb2964..7cb1c54849c4c27ef3b97273d5fb396b5cd82b7c 100644 (file)
@@ -1,32 +1,45 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit git-r3 linux-info systemd toolchain-funcs
+inherit linux-info systemd toolchain-funcs
 
 DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
 HOMEPAGE="https://github.com/dgraziotin/mbpfan"
-EGIT_REPO_URI="git://github.com/dgraziotin/${PN}.git"
 LICENSE="GPL-3+"
 SLOT="0"
 RESTRICT="test" # will fail if the hardware is unavailable, not useful
 
+if [[ "${PV}" = 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="git://github.com/dgraziotin/${PN}.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
 CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
 
-src_prepare() {
-       sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
-       default
+src_compile() {
+       emake CC="$(tc-getCC)"
 }
 
 src_install() {
-       emake DESTDIR="${D%/}" install
-
-       rm -r "${D}"usr/share/doc/${PN} || die
-       rm -r "${D}"lib/systemd/system || die
+       # There's a double linking problem in install
+       emake DESTDIR="${ED}" CC="$(tc-getCC)" install
 
-       newinitd ${PN}.init.gentoo ${PN}
+       # Remove the empty systemd unit directory
+       # It doesn't actually install the unit file
+       rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+       # Actually install the sytstemd unit file
        systemd_dounit ${PN}.service
+       # Install openrc init file
+       newinitd ${PN}.init.gentoo ${PN}
+
+       # make install doesn't install the docs in the right place
+       rm -rf "${ED%/}/usr/share/doc/${PN}" || die
 
        einstalldocs
 }