mail-mta/opensmtpd: modernize options
authorJason A. Donenfeld <zx2c4@gentoo.org>
Wed, 5 Feb 2020 12:10:01 +0000 (13:10 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Wed, 5 Feb 2020 12:16:28 +0000 (13:16 +0100)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
mail-mta/opensmtpd/opensmtpd-6.6.2_p1.ebuild

index 47ee74dbd8ec23bd92a459ba10e706ff6bb48aeb..001f39e82b74a0da44f283277ecce244ae8f01c8 100644 (file)
@@ -41,15 +41,15 @@ RDEPEND="${DEPEND}"
 S=${WORKDIR}/${P/_}
 
 src_configure() {
-       tc-export AR
-       AR="$(which "$AR")" econf \
-               --with-table-db \
+       econf \
+               --sysconfdir=/etc/smtpd \
+               --with-path-mbox=/var/spool/mail \
+               --with-path-empty=/var/empty \
+               --with-path-socket=/run \
+               --with-path-CAfile=/etc/ssl/certs/ca-certificates.crt \
                --with-user-smtpd=smtpd \
                --with-user-queue=smtpq \
                --with-group-queue=smtpq \
-               --with-path-socket=/run \
-               --with-path-CAfile=/etc/ssl/certs/ca-certificates.crt \
-               --sysconfdir=/etc/opensmtpd \
                $(use_with pam auth-pam)
 }
 
@@ -82,4 +82,10 @@ pkg_postinst() {
        einfo "Redis, and many other useful addons and filters are"
        einfo "available in the mail-filter/opensmtpd-extras package."
        einfo
+
+       ewarn
+       ewarn "If you're upgrading from version 6.0, note that the"
+       ewarn "configuration syntax has changed, and config files"
+       ewarn "now live in /etc/smtpd instead of /etc/opensmtpd."
+       ewarn
 }