www-misc/htdig: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Sat, 2 Jun 2018 23:14:09 +0000 (19:14 -0400)
committerAaron Bauman <bman@gentoo.org>
Sun, 3 Jun 2018 02:57:57 +0000 (22:57 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/8701

www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild [deleted file]
www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild [deleted file]

diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r3.ebuild
deleted file mode 100644 (file)
index 554832d..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils autotools
-
-MY_PV=${PV/_beta/b}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="HTTP/HTML indexing and searching system"
-HOMEPAGE="http://www.htdig.org"
-SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="ssl"
-
-DEPEND=">=sys-libs/zlib-1.1.3
-       app-arch/unzip
-       ssl? ( dev-libs/openssl )"
-
-src_unpack() {
-       unpack ${A}
-
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-gcc4.patch
-       epatch "${FILESDIR}"/${P}-as-needed.patch
-       epatch "${FILESDIR}"/${P}-quoting.patch
-       sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in db/configure.in || die
-       eautoreconf
-}
-
-src_compile() {
-       use prefix || EPREFIX=
-
-       econf \
-               --with-config-dir="${EPREFIX}"/etc/${PN} \
-               --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf \
-               --with-database-dir="${EPREFIX}"/var/lib/${PN}/db \
-               --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin \
-               --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
-               --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
-               $(use_with ssl)
-
-#              --with-image-url-prefix="file://${EPREFIX}/var/www/localhost/htdocs/${PN}" \
-
-       emake || die "emake failed"
-}
-
-src_install () {
-       use prefix || ED="${D}"
-
-       emake DESTDIR="${D}" install || die "make install failed"
-
-       dodoc ChangeLog README
-       dohtml -r htdoc
-
-       sed -i "s:${D}::g" \
-               "${ED}"/etc/${PN}/${PN}.conf \
-               "${ED}"/usr/bin/rundig \
-               || die "sed failed (removing \${D} from installed files)"
-
-       # symlink htsearch so it can be easily found. see bug #62087
-       dosym ../../var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
-}
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r4.ebuild
deleted file mode 100644 (file)
index 3a45503..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils autotools
-
-MY_PV=${PV/_beta/b}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-DESCRIPTION="HTTP/HTML indexing and searching system"
-HOMEPAGE="http://www.htdig.org"
-SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="libressl ssl"
-
-DEPEND=">=sys-libs/zlib-1.1.3
-       app-arch/unzip
-       ssl? (
-               !libressl? ( dev-libs/openssl:0 )
-               libressl? ( dev-libs/libressl )
-       )"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-gcc4.patch
-       epatch "${FILESDIR}"/${P}-as-needed.patch
-       epatch "${FILESDIR}"/${P}-quoting.patch
-       epatch "${FILESDIR}"/${P}-gcc6.patch
-       sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in db/configure.in || die
-       eautoreconf
-}
-
-src_configure() {
-       econf \
-               --with-config-dir="${EPREFIX}"/etc/${PN} \
-               --with-default-config-file="${EPREFIX}"/etc/${PN}/${PN}.conf \
-               --with-database-dir="${EPREFIX}"/var/lib/${PN}/db \
-               --with-cgi-bin-dir="${EPREFIX}"/var/www/localhost/cgi-bin \
-               --with-search-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
-               --with-image-dir="${EPREFIX}"/var/www/localhost/htdocs/${PN} \
-               $(use_with ssl)
-
-#              --with-image-url-prefix="file://${EPREFIX}/var/www/localhost/htdocs/${PN}" \
-}
-
-src_install () {
-       emake DESTDIR="${D}" install || die "make install failed"
-
-       dodoc ChangeLog README
-       dohtml -r htdoc
-
-       sed -i "s:${D}::g" \
-               "${ED}"/etc/${PN}/${PN}.conf \
-               "${ED}"/usr/bin/rundig \
-               || die "sed failed (removing \${D} from installed files)"
-
-       # symlink htsearch so it can be easily found. see bug #62087
-       dosym ../../var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
-}