dev-libs/klibc: Inline mirror://kernel
authorMichał Górny <mgorny@gentoo.org>
Mon, 30 Sep 2019 06:48:18 +0000 (08:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 5 Oct 2019 18:53:10 +0000 (20:53 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/klibc/klibc-2.0.4-r3.ebuild

index 9e4d06a4c598f5e78a723fb1fc98d1f3f4c5f9a1..0ce5d3b949572b7062befd9a7d382543e248608f 100644 (file)
@@ -30,7 +30,7 @@ if [[ ${PKV_EXTRA} ]]; then
        else
                PKV="${KV_MAJOR}.$((${KV_SUB}+1))-${PKV_EXTRA}"
        fi
-       PATCH_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/patch-${PKV}.${K_TARBALL_SUFFIX}"
+       PATCH_URI="https://www.kernel.org/pub/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/patch-${PKV}.${K_TARBALL_SUFFIX}"
 fi
 if [[ ${KV_MAJOR} == 2 ]]; then
        OKV="${KV_MAJOR}.${KV_MINOR}.${KV_SUB}"
@@ -38,13 +38,13 @@ else
        OKV="${KV_MAJOR}.${KV_SUB}"
 fi
 KERNEL_URI="
-       mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.${K_TARBALL_SUFFIX}
-       mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/testing/linux-${OKV}.tar.${K_TARBALL_SUFFIX}"
+       https://www.kernel.org/pub/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.${K_TARBALL_SUFFIX}
+       https://www.kernel.org/pub/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/testing/linux-${OKV}.tar.${K_TARBALL_SUFFIX}"
 DEBIAN_PV=2.0.4
 DEBIAN_PR=9
 DEBIAN_A="${PN}_${DEBIAN_PV}-${DEBIAN_PR}.debian.tar.xz"
 SRC_URI="
-       mirror://kernel/linux/libs/klibc/${PV:0:3}/${P}.tar.${K_TARBALL_SUFFIX}
+       https://www.kernel.org/pub/linux/libs/klibc/${PV:0:3}/${P}.tar.${K_TARBALL_SUFFIX}
        mirror://debian/pool/main/k/klibc/${DEBIAN_A}
        ${PATCH_URI}
        ${KERNEL_URI}"