www-apps/novnc: fix install and create /usr/bin symlink
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 17:10:46 +0000 (12:10 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 17:11:26 +0000 (12:11 -0500)
Closes: https://bugs.gentoo.org/714096
Closes: https://bugs.gentoo.org/714202
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
www-apps/novnc/novnc-1.1.0.ebuild
www-apps/novnc/novnc-9999.ebuild

index 130e5d594698080ac46b68c9a03a776f94421c54..734f516e33b9ae58de8886d5fb3cf0e847df5a84 100644 (file)
@@ -16,6 +16,7 @@ if [[ ${PV} == 9999 ]] ; then
 else
        SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+       S="${WORKDIR}/noVNC-${PV}"
 fi
 
 LICENSE="LGPL-3"
@@ -42,4 +43,5 @@ src_install() {
        insinto /usr/share/novnc
        doins -r vnc.html vnc_lite.html app/ core/ vendor/
        dosym vnc_lite.html /usr/share/novnc/vnc_auto.html  # for compat
+       dosym ../share/novnc/utils/launch.sh /usr/bin/novnc
 }
index 130e5d594698080ac46b68c9a03a776f94421c54..734f516e33b9ae58de8886d5fb3cf0e847df5a84 100644 (file)
@@ -16,6 +16,7 @@ if [[ ${PV} == 9999 ]] ; then
 else
        SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+       S="${WORKDIR}/noVNC-${PV}"
 fi
 
 LICENSE="LGPL-3"
@@ -42,4 +43,5 @@ src_install() {
        insinto /usr/share/novnc
        doins -r vnc.html vnc_lite.html app/ core/ vendor/
        dosym vnc_lite.html /usr/share/novnc/vnc_auto.html  # for compat
+       dosym ../share/novnc/utils/launch.sh /usr/bin/novnc
 }