net-dialup/accel-ppp: drop old versions
authorSergey Popov <pinkbyte@gentoo.org>
Wed, 9 Oct 2019 12:38:13 +0000 (15:38 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Wed, 9 Oct 2019 12:38:13 +0000 (15:38 +0300)
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

net-dialup/accel-ppp/Manifest
net-dialup/accel-ppp/accel-ppp-1.11.1_p20170508.ebuild [deleted file]
net-dialup/accel-ppp/accel-ppp-1.11.9999.ebuild [deleted file]
net-dialup/accel-ppp/files/accel-ppp-1.11.1-linux-4.10.patch [deleted file]

index 23f9de0f93afb28be3ddd2f5c1c940d9c8d2e56c..8cd346959bb897e7b66410254f672054ce1e9317 100644 (file)
@@ -1,2 +1 @@
-DIST accel-ppp-1.11.1_p20170508.tar.bz2 1609904 BLAKE2B 5993e25e09e84fa62fde28e6c79b11514eb5e0c365a8cc1a36c4e3e56ac868725b14049e28184188330ac78cb6c128429f2cc89241d871c02e4154c6882a89e2 SHA512 79f928c9d07891957d12443eaf32e96e826d5bebf241dcfcb31a7777fbce2332078bf0c1dd1e1a55cf96154be1fec610f1afd088fc018f54ebd5d265c037c07a
 DIST accel-ppp-1.11.1_p20180320.tar.bz2 1634359 BLAKE2B 97ca709ef3740c2ac1d75f6fba3acbf9229c3cb48f3a55735eaa14b74c2b0af96d637cbb145bc9e98a5b245704806cdc3d8f9d8692809626e0f73d73702c4a0a SHA512 a8a2420332c02087e45bbaab25831ae5d2d370fd56b29db77c267083badc22b90ca4b0ec7335e13250ac8f150002b2a3c343cfba6c2378932778777dc936d914
diff --git a/net-dialup/accel-ppp/accel-ppp-1.11.1_p20170508.ebuild b/net-dialup/accel-ppp/accel-ppp-1.11.1_p20170508.ebuild
deleted file mode 100644 (file)
index 07366eb..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2019 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils flag-o-matic linux-info linux-mod
-
-DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
-HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
-SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc ipoe lua postgres radius shaper snmp valgrind"
-
-RDEPEND="lua? ( dev-lang/lua:0 )
-       postgres? ( dev-db/postgresql:* )
-       snmp? ( net-analyzer/net-snmp )
-       dev-libs/libpcre
-       dev-libs/openssl:0"
-DEPEND="${RDEPEND}
-       valgrind? ( dev-util/valgrind )"
-PDEPEND="net-dialup/ppp-scripts"
-
-DOCS=( README )
-
-CONFIG_CHECK="~L2TP ~PPPOE ~PPTP"
-
-REQUIRED_USE="valgrind? ( debug )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.11.1-linux-4.10.patch"
-       "${FILESDIR}/${PN}-1.11.1-socklen.patch"
-)
-
-S="${WORKDIR}"
-
-pkg_setup() {
-       if use ipoe; then
-               linux-mod_pkg_setup
-               set_arch_to_kernel
-       else
-               linux-info_pkg_setup
-       fi
-}
-
-src_prepare() {
-       sed -i  -e "/mkdir/d" \
-               -e "/echo/d" \
-               -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
-
-       # Do not install kernel modules like that - breaks sandbox!
-       sed -i -e '/modules_install/d' \
-               drivers/ipoe/CMakeLists.txt \
-               drivers/vlan_mon/CMakeLists.txt || die
-
-       # Bug #549918
-       append-ldflags -Wl,-z,lazy
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local libdir="$(get_libdir)"
-       # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
-       local mycmakeargs=(
-               -DLIB_PATH_SUFFIX="${libdir#lib}"
-               -DBUILD_IPOE_DRIVER="$(usex ipoe)"
-               -DBUILD_PPTP_DRIVER=no
-               -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
-               -DCRYPTO=OPENSSL
-               -DLOG_PGSQL="$(usex postgres)"
-               -DLUA="$(usex lua)"
-               -DMEMDEBUG="$(usex debug)"
-               -DNETSNMP="$(usex snmp)"
-               -DRADIUS="$(usex radius)"
-               -DSHAPER="$(usex shaper)"
-               -DVALGRIND="$(usex valgrind)"
-       )
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-}
-
-src_install() {
-       if use ipoe; then
-               local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver) vlan_mon(accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver)"
-               linux-mod_src_install
-       fi
-
-       cmake-utils_src_install
-
-       use doc && dodoc -r rfc
-
-       if use snmp; then
-               insinto /usr/share/snmp/mibs
-               doins accel-pppd/extra/net-snmp/ACCEL-PPP-MIB.txt
-       fi
-
-       newinitd "${FILESDIR}"/${PN}.initd ${PN}d
-       newconfd "${FILESDIR}"/${PN}.confd ${PN}d
-
-       dodir /var/log/accel-ppp
-}
diff --git a/net-dialup/accel-ppp/accel-ppp-1.11.9999.ebuild b/net-dialup/accel-ppp/accel-ppp-1.11.9999.ebuild
deleted file mode 100644 (file)
index 817a5e3..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2019 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="git://git.code.sf.net/p/accel-ppp/code"
-EGIT_BRANCH="1.11"
-inherit cmake-utils flag-o-matic git-r3 linux-info linux-mod
-
-DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
-HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug doc ipoe lua postgres radius shaper snmp valgrind"
-
-RDEPEND="lua? ( dev-lang/lua:0 )
-       postgres? ( dev-db/postgresql:* )
-       snmp? ( net-analyzer/net-snmp )
-       dev-libs/libpcre
-       dev-libs/openssl:0"
-DEPEND="${RDEPEND}
-       valgrind? ( dev-util/valgrind )"
-PDEPEND="net-dialup/ppp-scripts"
-
-DOCS=( README )
-
-CONFIG_CHECK="~L2TP ~PPPOE ~PPTP"
-
-REQUIRED_USE="valgrind? ( debug )"
-
-pkg_setup() {
-       if use ipoe; then
-               linux-mod_pkg_setup
-               set_arch_to_kernel
-       else
-               linux-info_pkg_setup
-       fi
-}
-
-src_prepare() {
-       sed -i  -e "/mkdir/d" \
-               -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
-
-       # Do not install kernel modules like that - breaks sandbox!
-       sed -i -e '/modules_install/d' \
-               drivers/ipoe/CMakeLists.txt \
-               drivers/vlan_mon/CMakeLists.txt || die
-
-       # Bug #549918
-       append-ldflags -Wl,-z,lazy
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local libdir="$(get_libdir)"
-       # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
-       local mycmakeargs=(
-               -DLIB_SUFFIX="${libdir#lib}"
-               -DBUILD_IPOE_DRIVER="$(usex ipoe)"
-               -DBUILD_PPTP_DRIVER=no
-               -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
-               -DCRYPTO=OPENSSL
-               -DLOG_PGSQL="$(usex postgres)"
-               -DLUA="$(usex lua)"
-               -DMEMDEBUG="$(usex debug)"
-               -DNETSNMP="$(usex snmp)"
-               -DRADIUS="$(usex radius)"
-               -DSHAPER="$(usex shaper)"
-               $(use debug && echo "-DVALGRIND=$(usex valgrind)")
-       )
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-}
-
-src_install() {
-       if use ipoe; then
-               local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver) vlan_mon(accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver)"
-               linux-mod_src_install
-       fi
-
-       cmake-utils_src_install
-
-       use doc && dodoc -r rfc
-
-       if use snmp; then
-               insinto /usr/share/snmp/mibs
-               doins accel-pppd/extra/net-snmp/ACCEL-PPP-MIB.txt
-       fi
-
-       newinitd "${FILESDIR}"/${PN}.initd ${PN}d
-       newconfd "${FILESDIR}"/${PN}.confd ${PN}d
-
-       dodir /var/log/accel-ppp
-}
diff --git a/net-dialup/accel-ppp/files/accel-ppp-1.11.1-linux-4.10.patch b/net-dialup/accel-ppp/files/accel-ppp-1.11.1-linux-4.10.patch
deleted file mode 100644 (file)
index 568a405..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
---- ./drivers/ipoe/ipoe.c.orig 2016-11-28 14:28:33.000000000 +0300
-+++ ./drivers/ipoe/ipoe.c      2017-05-17 11:27:42.030000000 +0300
-@@ -52,6 +52,27 @@
- #define DEFINE_SEMAPHORE(name) struct semaphore name = __SEMAPHORE_INITIALIZER(name, 1)
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)
-+static inline int
-+_genl_register_family_with_ops_grps(struct genl_family *family,
-+                                  const struct genl_ops *ops, size_t n_ops,
-+                                  const struct genl_multicast_group *mcgrps,
-+                                  size_t n_mcgrps)
-+{
-+      family->module = THIS_MODULE;
-+      family->ops = ops;
-+      family->n_ops = n_ops;
-+      family->mcgrps = mcgrps;
-+      family->n_mcgrps = n_mcgrps;
-+      return genl_register_family(family);
-+}
-+
-+#define genl_register_family_with_ops_groups(family, ops, grps)       \
-+      _genl_register_family_with_ops_grps((family),                   \
-+                                          (ops), ARRAY_SIZE(ops),     \
-+                                          (grps), ARRAY_SIZE(grps))
-+#endif
-+
- struct ipoe_stats {
-       struct u64_stats_sync sync;
-       u64 packets;
-@@ -1668,7 +1689,9 @@
- };
- static struct genl_family ipoe_nl_family = {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,10,0)
-       .id             = GENL_ID_GENERATE,
-+#endif
-       .name           = IPOE_GENL_NAME,
-       .version        = IPOE_GENL_VERSION,
-       .hdrsize        = 0,
---- ./drivers/vlan_mon/vlan_mon.c.orig 2017-05-17 11:28:23.320000000 +0300
-+++ ./drivers/vlan_mon/vlan_mon.c      2017-05-17 11:29:41.660000000 +0300
-@@ -39,6 +39,27 @@
- #define vlan_tx_tag_present(skb) skb_vlan_tag_present(skb)
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)
-+static inline int
-+_genl_register_family_with_ops_grps(struct genl_family *family,
-+                                  const struct genl_ops *ops, size_t n_ops,
-+                                  const struct genl_multicast_group *mcgrps,
-+                                  size_t n_mcgrps)
-+{
-+      family->module = THIS_MODULE;
-+      family->ops = ops;
-+      family->n_ops = n_ops;
-+      family->mcgrps = mcgrps;
-+      family->n_mcgrps = n_mcgrps;
-+      return genl_register_family(family);
-+}
-+
-+#define genl_register_family_with_ops_groups(family, ops, grps)       \
-+      _genl_register_family_with_ops_grps((family),                   \
-+                                          (ops), ARRAY_SIZE(ops),     \
-+                                          (grps), ARRAY_SIZE(grps))
-+#endif
-+
- struct vlan_dev {
-       unsigned int magic;
-       int ifindex;
-@@ -660,7 +681,9 @@
- };
- static struct genl_family vlan_mon_nl_family = {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,10,0)
-       .id             = GENL_ID_GENERATE,
-+#endif
-       .name           = VLAN_MON_GENL_NAME,
-       .version        = VLAN_MON_GENL_VERSION,
-       .hdrsize        = 0,