sys-fs/xfsprogs: Use use_enable for static-libs
authorSven Wegener <swegener@gentoo.org>
Sat, 20 Oct 2018 22:13:32 +0000 (22:13 +0000)
committerSven Wegener <swegener@gentoo.org>
Sat, 20 Oct 2018 22:14:04 +0000 (22:14 +0000)
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild

index 9c4506c9ced4d3f757841d2aa0f23ad917c9ca81..70e095eb507f98e299ce19bf56e02691786758b0 100644 (file)
@@ -61,12 +61,8 @@ src_configure() {
                $(use_enable nls gettext)
                $(use_enable readline)
                $(usex readline --disable-editline $(use_enable libedit editline))
+               $(use_enable static-libs static)
        )
-       if use static-libs ; then
-               myconf+=( --enable-static )
-       else
-               myconf+=( --disable-static )
-       fi
 
        econf "${myconf[@]}"
 
index 75efba7d259434e4ea756715a274369a5ae0ee80..ac490a41e2892edac802efb38e62b620af06cea0 100644 (file)
@@ -61,12 +61,8 @@ src_configure() {
                $(use_enable nls gettext)
                $(use_enable readline)
                $(usex readline --disable-editline $(use_enable libedit editline))
+               $(use_enable static-libs static)
        )
-       if use static-libs ; then
-               myconf+=( --enable-static )
-       else
-               myconf+=( --disable-static )
-       fi
 
        econf "${myconf[@]}"