x11-terms/kitty-terminfo: split live ebuild
authorend222 <pabloorduna98@gmail.com>
Sat, 11 Apr 2020 21:25:27 +0000 (23:25 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 13 Apr 2020 08:31:18 +0000 (11:31 +0300)
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15308
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild [new file with mode: 0644]

diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
new file mode 100644 (file)
index 0000000..b43704c
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg git-r3
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+       "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+       "${EPYTHON}" setup.py \
+               --verbose $(usex debug --debug "") \
+               --libdir-name $(get_libdir) \
+               linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+       insinto /usr
+       doins -r linux-package/*
+}