x11-misc/obconf-qt: add version 0.15.0
authorJimi Huotari <chiitoo@gentoo.org>
Wed, 29 Apr 2020 23:34:05 +0000 (02:34 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:32 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-misc/obconf-qt/Manifest
x11-misc/obconf-qt/obconf-qt-0.15.0.ebuild [new file with mode: 0644]

index 908d81f98dce29fc8f5ff3f0e8845e38458828ee..53e04af4d9c861e8247b9339db98567bf9faa100 100644 (file)
@@ -1 +1,2 @@
 DIST obconf-qt-0.14.1.tar.xz 97032 BLAKE2B 8bfe93325d37bdcca40b38f99f635cddf39ad1781e694f002676f6ff6fd0d6c708908ca458a051f63509f572b247b4de5778a1451e763c4372038ef99a1594d7 SHA512 7ae4feb8daa3853f768e9cb613fc99046f98744e03efc673ee9e5cb3d4ffa2861f2a9f762acd9c54ef2b9ca3f288d2901cdcce5c09db84689dd186006b8e26ed
+DIST obconf-qt-0.15.0.tar.xz 99976 BLAKE2B 7c7aede61cfc7a26c56de7e6ab49410dc82f4f9fb4f293fa0f0896f1b14cff63d34d00dd56347ec8daca375e226fed4ebb58c633061129708fd5107daa97d074 SHA512 a723dcd3b409afc7b16572d293cbf0543e00a7177a9819e2374632c00c765de74896429f6e19a54fcee83e20ce2e0876f857447c374db2f4f925dec92be71279
diff --git a/x11-misc/obconf-qt/obconf-qt-0.15.0.ebuild b/x11-misc/obconf-qt/obconf-qt-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..4979e3f
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Openbox Configuration Tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+       virtual/pkgconfig
+"
+DEPEND="
+       dev-libs/glib:2
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       sys-apps/sed
+       x11-wm/openbox:3
+       x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}