dev-haskell/aeson-pretty: bump up to 0.8.8
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Dec 2019 11:13:34 +0000 (11:13 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Dec 2019 11:16:32 +0000 (11:16 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/aeson-pretty/Manifest
dev-haskell/aeson-pretty/aeson-pretty-0.8.8.ebuild [new file with mode: 0644]

index 7b3a793eee9505e5935432a007f76a30dd9332da..b0cfebb396a976f144e7579acf91e670eb0ac906 100644 (file)
@@ -1,3 +1,4 @@
 DIST aeson-pretty-0.7.1.tar.gz 4811 BLAKE2B 4a8cb1d51376cdc403f5bbff92b012ca6e88bc02283cfe2a0990611a7b74153d820a4d5b826b92f58d8afa14e67b5336453864add33e7716efd9bc0adc949cde SHA512 53522c5235b8252c0a293ebe6a988cfb7f61cc575df664a27851652a47b948acd322898e70e128c91d1aaf6b5bd27c8a1717edcc3ea423f34e7943791a301326
 DIST aeson-pretty-0.7.2.tar.gz 4838 BLAKE2B cc2ae346a7fbc13f854cf4bb716be68b2e45e2c15848cc5b77c15275fe0d43288a1987e5a95835ba923269612b8914338fca5e25c0ce66e59d9798a4e821ec55 SHA512 beabdb13c1a7c5a8fa7acdfe0e0f7b6b00d901d6aada360c17e43704cddd92d6464901885dd529710cc090c9649aa63b7241a5155178f0ff27145ed1ef4f347b
 DIST aeson-pretty-0.8.2.tar.gz 5456 BLAKE2B 7fef48f20aca649a49b84f79790ad7b6605c5f4655a5d8bea965104ffed0436449ebed7b6f40079164e86d4a016c7259fc48d35ce1e74caff5c805d7599bef15 SHA512 ec3af960b6afff9eb25d3679c23f8c627b9baeb0c10bcd9eb1ac60cc118988e6e47904d7e93bb4e260578fa41b58cfa7bd797fa5e0043c985a8f2b574b7d243a
+DIST aeson-pretty-0.8.8.tar.gz 5600 BLAKE2B cac5605b17405868ea373806021e9ba2b3bd3bcb864e97067d4086289a53c2118922e318fb966172a0c0cf0df900e577698afdcea1291464151fc0a01f359dde SHA512 5867343c5d51d632bb299fcbc00cdb29b0feb1931f0ff9c3cf89c5752f1a103c68c9e6fa65e8538ac19212853c39f6d1d6e0c2d9f0bf49fe001c1bfd792db779
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.8.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.8.ebuild
new file mode 100644 (file)
index 0000000..9e23eef
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+       >=dev-haskell/base-compat-0.9:=[profile?]
+       >=dev-haskell/scientific-0.3:=[profile?]
+       >=dev-haskell/semigroups-0.18.2:=[profile?]
+       >=dev-haskell/text-0.11:=[profile?]
+       >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+       >=dev-haskell/vector-0.9:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+       !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+                       >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               $(cabal_flag lib-only lib-only)
+}