dev-libs/libcroco: version bump to 0.6.10
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 13 Dec 2015 22:09:07 +0000 (23:09 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 13 Dec 2015 22:10:22 +0000 (23:10 +0100)
Package-Manager: portage-2.2.26

dev-libs/libcroco/Manifest
dev-libs/libcroco/libcroco-0.6.10.ebuild [new file with mode: 0644]

index 394c8a54bd15f39e4a457fecd44762c34e96b4e8..77a507ac8c2861424d05d9bd6605ad6a05a04d05 100644 (file)
@@ -1,2 +1,3 @@
+DIST libcroco-0.6.10.tar.xz 476928 SHA256 72066611df77f5c4fb28268cfc7306ecc1517212a6182c2ea756c326a154246c SHA512 c990fc7873f6c6bf2c6994409cb7f79aa19a73a44d4b62a5dae81c2f9ff587cf6c778a87dc3e0d32da6df5a6764f39feed9d39938cdb8056d198ff869b2e6839 WHIRLPOOL 6ffce77ee04be812d81863dde90ff1461ae6449722366ab7e116fd0bdbe0c8ab0838c59986283cb00799e1061f3e83516e067685f7a53c3f2f58fb8bc81c437b
 DIST libcroco-0.6.8.tar.xz 464992 SHA256 ea6e1b858c55219cefd7109756bff5bc1a774ba7a55f7d3ccd734d6b871b8570 SHA512 acfbebb59e5ea1e70da41f35970fb40a58331a1258eee6c981a575fdd23b420b4cc6d8983c90ad1e6afc0a461e675cb24667e03cfc8ec1aa5e9918e606913413 WHIRLPOOL 704fd5d6df6d62c15645b9901b807e5fd8916567fd32b975f4bd0ce013126617cc16e6a14fc334d0733012cfde8403978f5a23c1254fcdfae156a0720fa266e7
 DIST libcroco-0.6.9.tar.xz 475844 SHA256 38b9a6aed1813e55b3ca07a68d1af845ad4d1f984602e9272fe692930c0be0ae SHA512 2bdb16a9004ff7304bc3cf91495925d1502c165b54dc1121d2f0fc9b627ec9c5b81e78b48e3f092855c3accc3295e5a3870eb6225ddb1b1fcd037004af78583b WHIRLPOOL 59767afbbb9a180eb87a5821ec85df50f85a16d687687de1267c86218d1bc587bf37759ba05a34bf0d109dc8e5b7b69209c5c5bdf930fd721e42533670bdb523
diff --git a/dev-libs/libcroco/libcroco-0.6.10.ebuild b/dev-libs/libcroco/libcroco-0.6.10.ebuild
new file mode 100644 (file)
index 0000000..74ab744
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+HOMEPAGE="https://git.gnome.org/browse/libcroco/"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+       if ! use test; then
+               # don't waste time building tests
+               sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+                       || die "sed failed"
+       fi
+
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               $([[ ${CHOST} == *-darwin* ]] && echo --disable-Bsymbolic)
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/reference/html docs/reference/html || die
+       fi
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+       einstalldocs
+}