dev-python/keystonemiddleware: bup for liberty
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 7 Oct 2015 04:16:20 +0000 (23:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 7 Oct 2015 04:16:20 +0000 (23:16 -0500)
Package-Manager: portage-2.2.20.1

dev-python/keystonemiddleware/Manifest
dev-python/keystonemiddleware/keystonemiddleware-2.3.1.ebuild [new file with mode: 0644]

index 9b65ac96b1a2ac483a5cd570c0017289a75c3a9a..16fa7643ea861eddef993be1aa49dfd7ce15fe5a 100644 (file)
@@ -1,3 +1,4 @@
 DIST keystonemiddleware-1.5.0.tar.gz 176315 SHA256 73e98aab8bceb7843b6cc8aba2cbff824a379428519e2f9ffbb8e32578b38fe8 SHA512 365643f7eba633587d8055204df04cfb40bdcc28c57d7ecf8c4ed67803b9b027b6334f868a1bc634d9beefd7410d74da08a7ed599637ec1656e6ef6196043dab WHIRLPOOL da7014869d3fc1ac5339671344542e33c22ac07adfb76ad00144cdcf4e1e26c60eea7ca7867cea6c6e105af1d05be64eff7d55ae1b3cf5114597da966b756b55
 DIST keystonemiddleware-1.5.2.tar.gz 176172 SHA256 5f443162157946d2f33c4729d0bde55291f12963b0f1ee553984aedd8a509d51 SHA512 172143f2e80860de3d89f53667bf670c1986cfc63a21392bf977b3beaa5669db76f46997d6939952856cb4abc970b57920810980d00db7e7cd711bdbede5908e WHIRLPOOL 99a4553778b5dae07a710e78f816c8b30def42bfc7024cac7d6be8d8b6f76326383ed72935c6526758ac65fb26945937869985cba167d8804fe3a7cf2e3c4208
 DIST keystonemiddleware-2.2.0.tar.gz 179743 SHA256 e3fca3fdc093d7fd3817bbd767faca7f0aa221b54155808694eb1286fae469f9 SHA512 9aa498aa0bceec1774c70dc7fc4ce8c398e72721d33e715594b3396e160f9b60dfc3533687f0706eb272abd812b44d31b2a76fece739a2ccad33039b37f3fca5 WHIRLPOOL a1b348e3e2f004038afa6b2b06d018d2e1130af1b2eb0e5740ea6a716dabaa98fe7a58cfd6e5100e5cdd6c7297fb150f4d9cc45dd8c831b7ca54a265b0d56662
+DIST keystonemiddleware-2.3.1.tar.gz 181764 SHA256 9970f8187cb0a91cb2d78ef9a088147b2c9457653e95caa7b8bcd11bd450bec1 SHA512 976aece1d308607eec6f406bb94f1e6dddc27edebc8d99bd7bc00dfbc1f21479da2c76404a99eb677e6647afd42f68b82d6f519659d7483db6fa9d68f839cf5f WHIRLPOOL e6a568e7c96886907eaeba9bc843833ffece8f441bfbe760b77c597c38a5a2720b702a527830d61f07bf0e3adbe4a90d6198b97b487ca08c3e4829058f7e0ef4
diff --git a/dev-python/keystonemiddleware/keystonemiddleware-2.3.1.ebuild b/dev-python/keystonemiddleware/keystonemiddleware-2.3.1.ebuild
new file mode 100644 (file)
index 0000000..18bd9b7
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+#PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A middleware for the OpenStack Keystone API"
+HOMEPAGE="https://github.com/openstack/keystonemiddleware"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+               >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-messaging-1.16.0[${PYTHON_USEDEP}]
+               !~dev-python/oslo-messaging-1.17.0[${PYTHON_USEDEP}]
+               !~dev-python/oslo-messaging-1.17.1[${PYTHON_USEDEP}]
+               >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+               >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+               >=dev-python/python-memcached-1.56[${PYTHON_USEDEP}]
+               >=dev-python/bandit-0.13.2[${PYTHON_USEDEP}]
+       )"
+
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
+       >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]"
+
+PATCHES=(
+)
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       testr init
+       testr run || die "testsuite failed under python2.7"
+       flake8 ${PN/python-/}/tests || die "run over tests folder by flake8 drew error"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+       use examples && local EXAMPLES=( examples/.)
+       distutils-r1_python_install_all
+}