app-office/calcurse: wire up python-single-r1
authorMike Gilbert <floppym@gentoo.org>
Thu, 12 Mar 2020 20:45:27 +0000 (16:45 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 12 Mar 2020 20:49:19 +0000 (16:49 -0400)
Package-Manager: Portage-2.3.92_p3, Repoman-2.3.20_p118
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
app-office/calcurse/calcurse-4.4.0-r1.ebuild [moved from app-office/calcurse/calcurse-4.4.0.ebuild with 61% similarity]

similarity index 61%
rename from app-office/calcurse/calcurse-4.4.0.ebuild
rename to app-office/calcurse/calcurse-4.4.0-r1.ebuild
index aed85d935654e98c22859c49a7d1fc2332a6217d..4f73bc667627a0511f2f67b4828dd40f9983e06c 100644 (file)
@@ -2,8 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
+PYTHON_COMPAT=( python3_{6..8} )
 
-inherit autotools eutils
+inherit autotools eutils python-single-r1
 
 DESCRIPTION="a text-based calendar and scheduling application"
 HOMEPAGE="https://calcurse.org/"
@@ -12,9 +13,11 @@ SRC_URI="https://calcurse.org/files/${P}.tar.gz"
 LICENSE="BSD-2"
 SLOT="0"
 KEYWORDS="amd64 ppc ppc64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="
-       dev-python/httplib2
+       ${PYTHON_DEPS}
+       $(python_gen_cond_dep 'dev-python/httplib2[${PYTHON_MULTI_USEDEP}]')
        sys-libs/ncurses:0="
 
 DEPEND="
@@ -27,7 +30,17 @@ PATCHES=(
 # Most tests fail.
 RESTRICT="test"
 
+pkg_setup() {
+       :
+}
+
 src_prepare() {
        default
        eautoreconf
 }
+
+src_compile() {
+       default
+       python_setup
+       python_fix_shebang contrib/caldav/calcurse-caldav
+}