dev-haskell/parsec1: new package, a depend onf xmobar-0.32
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 29 May 2020 20:52:54 +0000 (21:52 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 29 May 2020 20:57:47 +0000 (21:57 +0100)
Portable monadic parser combinators

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/parsec1/Manifest [new file with mode: 0644]
dev-haskell/parsec1/metadata.xml [new file with mode: 0644]
dev-haskell/parsec1/parsec1-1.0.0.6.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/parsec1/Manifest b/dev-haskell/parsec1/Manifest
new file mode 100644 (file)
index 0000000..34fd3d3
--- /dev/null
@@ -0,0 +1 @@
+DIST parsec1-1.0.0.6.tar.gz 13871 BLAKE2B 4159797292ee8a5a64ec53c324fab116aad1c3974183c978b6e43a124e58e897b5115ff36349218b8c57fd2a69c54b592322dfa7c0cfc20761490d7f0c205d82 SHA512 1372007edd048aa5cca20f44fe70041b238c0b5aa36ed2c189124072f5d7671d3d164cbad58c8ce3f5c7bff01096fc9deec80cd21edc5475eecae12d2c4c6c38
diff --git a/dev-haskell/parsec1/metadata.xml b/dev-haskell/parsec1/metadata.xml
new file mode 100644 (file)
index 0000000..b0ea7c4
--- /dev/null
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               Parsec is designed from scratch as an industrial-strength parser
+               library.  It is simple, safe, well documented (on the package
+               homepage), has extensive libraries and good error messages,
+               and is also fast.
+               
+               This package is the core haskell98 part of the parsec2
+               package, intended to preserve its simplicity and portability.
+               
+               Note, that the module names overlap with those of parsec from the Haskell
+               Platform, therefore I do not recommend to unconditionally use parsec1 (or
+               parsec2 and parsec3) as dependency in cabal files of packages for hackage.
+               But you may want to develop your code using these limited and portable
+               parsec1 functions and finally change the dependency from parsec1 to parsec
+               in order to avoid module ambiguities for users just installing your package.
+               Your own module ambiguities are best avoided by hiding packages.
+               
+               This version only differs from the pervious one by improved error messages
+               for try (positions are not reset), tokens and thus string (longer
+               unexpected strings are now reported to match the error position).
+               The notFollowedBy-parser was generalized (as in parsec-3) so
+               characters in messages are now shown in single instead of double
+               quotes.
+               Also (as since parsec-3.1.2) lookAhead no longer consumes tokens on success
+               (so that the many-parser can detect this).
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parsec1/parsec1-1.0.0.6.ebuild b/dev-haskell/parsec1/parsec1-1.0.0.6.ebuild
new file mode 100644 (file)
index 0000000..6af8931
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Portable monadic parser combinators"
+HOMEPAGE="http://www.cs.uu.nl/~daan/parsec.html"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.6
+"