sci-geosciences/opencpn-plugin-statusbar: added snapshot version
authorMarc Schiffbauer <mschiff@gentoo.org>
Fri, 16 Mar 2018 23:07:12 +0000 (00:07 +0100)
committerMarc Schiffbauer <mschiff@gentoo.org>
Fri, 16 Mar 2018 23:46:01 +0000 (00:46 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sci-geosciences/opencpn-plugin-statusbar/Manifest
sci-geosciences/opencpn-plugin-statusbar/opencpn-plugin-statusbar-0.5.20180316.ebuild [new file with mode: 0644]
sci-geosciences/opencpn-plugin-statusbar/opencpn-plugin-statusbar-9999.ebuild

index c855503122398ea8f978b6bcdbb22e030df6fa96..4d961c7eeae07b799c0607c552517f1ddadf0017 100644 (file)
@@ -1 +1,2 @@
+DIST opencpn-plugin-statusbar-0.5.20180316.tar.gz 218364 BLAKE2B d1da43ec085e1d180fca524c44ae2f6410b0f74a1f65dc5d586087a46b6f2735a60e3e5332f072d181e0a23a9d2f254a9b0f5872e81a749a3af4fa65c3a997c3 SHA512 9ea70258367d5370fd70d894c098fe781141505a18365d197b58f30e65df57f7b0fd9c5e4bc95603d89f5dd49cc7ef5bcc921f6cd2d12d407686446551ce4eca
 DIST opencpn-plugin-statusbar-0.5.tar.gz 86323 BLAKE2B 1023563fabba859a9528381a00b1ecf607d20fe65fdfb9d1e6839fa82a8c613b125e59d6009d530d5f4196efbbc2a5cd1f9c6eb606c4ee8303983f974d13f22c SHA512 cf723717f41c87b3e7dd40c1d485f873d336f598fe022adf418290443333fd19d874d294bd4b36bea10e026fdf0e27b76d098196ba0aace360ae86c103c6e1b4
diff --git a/sci-geosciences/opencpn-plugin-statusbar/opencpn-plugin-statusbar-0.5.20180316.ebuild b/sci-geosciences/opencpn-plugin-statusbar/opencpn-plugin-statusbar-0.5.20180316.ebuild
new file mode 100644 (file)
index 0000000..307e60f
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="statusbar_pi"
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+       inherit git-r3 cmake-utils wxwidgets
+       KEYWORDS=""
+else
+       SRC_URI="
+               https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       "
+       inherit cmake-utils wxwidgets
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Statusbar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/seandepagnier/statusbar_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       x11-libs/wxGTK:${WX_GTK_VER}
+       >=sci-geosciences/opencpn-4.2.0
+       sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+       need-wxwidgets unicode
+       cmake-utils_src_prepare
+}
index ad141e70ffc695f602bb5d1c3a8bd173668d1cfe..307e60fb53a3c8f2b105fbb377e3924fac64e11b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
        KEYWORDS=""
 else
        SRC_URI="
-               https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+               https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
        "
        inherit cmake-utils wxwidgets
        KEYWORDS="~amd64 ~x86"