gui-apps/kanshi: autorandr for wayland clients
authorAisha Tammy <gentoo@aisha.cc>
Mon, 18 May 2020 11:51:29 +0000 (07:51 -0400)
committerAaron Bauman <bman@gentoo.org>
Mon, 18 May 2020 21:37:25 +0000 (17:37 -0400)
Closes: https://bugs.gentoo.org/723746

kanshi allows you to define output profiles that
are automatically enabled and disabled on hotplug.
For instance, this can be used to turn a laptop's
internal screen off when docked.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Closes: https://github.com/gentoo/gentoo/pull/15865
Signed-off-by: Aaron Bauman <bman@gentoo.org>
gui-apps/kanshi/Manifest [new file with mode: 0644]
gui-apps/kanshi/kanshi-1.1.0.ebuild [new file with mode: 0644]
gui-apps/kanshi/kanshi-9999.ebuild [new file with mode: 0644]
gui-apps/kanshi/metadata.xml [new file with mode: 0644]

diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
new file mode 100644 (file)
index 0000000..8c01965
--- /dev/null
@@ -0,0 +1 @@
+DIST kanshi-1.1.0.tar.gz 15884 BLAKE2B 1085e9d8f3ff53f78cb248941269713fd7ea38c60ad0e9816acb902f171b6f945af521a3835fc9db479620e6031483f6dbab5cfc507872dcabdfbcf9d6711269 SHA512 6582bae7b73ad13cad83e4d537c7c870699a72bf6993becaafa47a3dd70439a3c626ffff4874c8f737b32b62ad7512772c2c3bf54ac2cb74879213bd40b8d7a1
diff --git a/gui-apps/kanshi/kanshi-1.1.0.ebuild b/gui-apps/kanshi/kanshi-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..221a5f5
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+       SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+       dev-libs/wayland
+"
+BDEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+       BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+       BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+       local emesonargs=(
+               $(meson_feature man man-pages)
+       )
+       meson_src_configure
+}
diff --git a/gui-apps/kanshi/kanshi-9999.ebuild b/gui-apps/kanshi/kanshi-9999.ebuild
new file mode 100644 (file)
index 0000000..221a5f5
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://github.com/emersion/kanshi"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+       SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+       dev-libs/wayland
+"
+BDEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+       BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+       BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+       local emesonargs=(
+               $(meson_feature man man-pages)
+       )
+       meson_src_configure
+}
diff --git a/gui-apps/kanshi/metadata.xml b/gui-apps/kanshi/metadata.xml
new file mode 100644 (file)
index 0000000..21d7750
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+    <longdescription>
+        kanshi allows you to define output profiles that
+        are automatically enabled and disabled on hotplug.
+        For instance, this can be used to turn a laptop's
+        internal screen off when docked.
+    </longdescription>
+    <use>
+        <flag name="man">build and install man pages</flag>
+    </use>
+</pkgmetadata>