app-laptop/pbbuttonsd: drop old EAPI=0 ebuilds
authorAaron Bauman <bman@gentoo.org>
Sat, 2 Jun 2018 19:57:40 +0000 (15:57 -0400)
committerAaron Bauman <bman@gentoo.org>
Sat, 2 Jun 2018 22:36:59 +0000 (18:36 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-laptop/pbbuttonsd/Manifest
app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r3.ebuild [deleted file]
app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r4.ebuild [deleted file]

index 9abb5c4a6692c973c7a12225f4f8951b262d88c2..797ddc84c0fe6abc857ce7e977bdcc9ad4388d4f 100644 (file)
@@ -1,2 +1 @@
-DIST pbbuttonsd-0.8.1.tar.gz 589630 BLAKE2B 6cc9e8cfdbb3878be38d3e06f84af08f1c0dcdca23868c2b04c3812bb8d69780dbe86911b6c58a2a7345b39a19fffb2536ca7f0230ec8159710505b86c2b3ebe SHA512 856f8533c1f6489986c232baa8b8002a01d009ed3728ee35bc723aece91ba626ce961119c0d424f40c2f9289827f317c56d70fe8f0e035cbd9f08d7701316ac3
 DIST pbbuttonsd-0.8.1a.tar.gz 589747 BLAKE2B a0410b7f165e8a0f5b6efa8fa86cc32a84e62da08141d285442d48f0e541d4d6d063e61a7e48aa7901135c4fc9640a7968be821619b3741ce30ba1497015aad4 SHA512 4aaf674872982925f7aa8e06a363f50830f13d9491f4a3b850c1852a8a6d4b2c72164f839c482eed059703dd25d900fe3bb774f78e7039ac2464ea7a1837bf99
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r3.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r3.ebuild
deleted file mode 100644 (file)
index 6b240e0..0000000
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit autotools flag-o-matic eutils
-
-DESCRIPTION="Handles power management and special keys on laptops"
-HOMEPAGE="http://pbbuttons.berlios.de"
-SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc ~x86"
-IUSE="acpi alsa debug doc ibam macbook oss"
-
-DEPEND="macbook? (
-                       sys-libs/libsmbios
-                       sys-apps/pciutils
-               )
-               >=dev-libs/glib-2.6
-               doc? ( app-doc/doxygen )"
-RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
-                >=dev-libs/glib-2.6"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       epatch "${FILESDIR}/${PN}-0.8.1-pmcs.patch"
-       ### Don't link with g++ if we don't use ibam
-       if ! use ibam; then
-               epatch "${FILESDIR}/${PN}-0.8.1-g++.patch"
-       fi
-       ### Fix macbook -lz issue
-       epatch "${FILESDIR}/${PN}-0.8.1-lz.patch"
-       epatch "${FILESDIR}/${PN}-0.8.1-lm.patch"
-       ### Fix new apple hid fnmode issue
-       epatch "${FILESDIR}/${PN}-0.8.1-fnmode.patch"
-       eautoconf
-}
-
-src_compile() {
-       # Fix crash bug on some systems
-       replace-flags -O? -O1
-
-       if use macbook; then
-               laptop=macbook
-       elif use x86 || use amd64; then
-               if use acpi; then
-                       laptop=acpi
-               else
-                       laptop=i386
-               fi
-       # Default to PowerBook
-       else
-               laptop=powerbook
-       fi
-
-       econf laptop=$laptop \
-               $(use_enable debug) \
-               $(use_with doc doxygen_docs) \
-               $(use_with alsa) \
-               $(use_with oss) \
-               $(use_with ibam) \
-               || die "Sorry, failed to configure pbbuttonsd"
-
-       # Thanks to Stefan Bruda for this workaround
-       # Using -j1 fixes a parallel build issue with the docs
-       if use doc; then
-               emake -j1 || die "Sorry, failed to compile pbbuttonsd"
-       else
-               emake || die "Sorry, failed to compile pbbuttonsd"
-       fi
-}
-
-src_install() {
-       dodir /etc/power
-       use ibam && dodir /var/lib/ibam
-       make DESTDIR="${D}" install || die "failed to install"
-       newinitd "${FILESDIR}/pbbuttonsd.rc6" pbbuttonsd
-       dodoc README
-       use doc && dohtml -r doc/*
-
-       dodir /etc/power/resume.d
-       dodir /etc/power/suspend.d
-       dodir /etc/power/scripts.d
-       exeinto "/etc/power/scripts.d"
-       doexe "${FILESDIR}/wireless"
-       ln -s "${D}/etc/power/scripts.d/wireless" "${D}/etc/power/resume.d/wireless"
-}
-
-pkg_postinst() {
-       if [ -e /etc/pbbuttonsd.conf ]; then
-               ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
-               ewarn "file (/etc/pbbuttonsd.conf) and a new format.  Please check the"
-               ewarn "manual page with 'man pbbuttonsd.cnf' for details."
-               ewarn
-       fi
-
-       if use macbook; then
-               ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
-               ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
-               ewarn "will not work and pbbuttonsd may segfault."
-       fi
-
-       ewarn "Ensure that the evdev kernel module is loaded otherwise"
-       ewarn "pbbuttonsd won't work.  SysV IPC is also required."
-       ewarn
-       ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
-       ewarn "input from one user.  You can set the userallowed option in"
-       ewarn "/etc/pbbuttonsd.cnf to limit access."
-       ewarn
-
-       if use ibam; then
-               elog "To properly initialize the IBaM battery database, you will"
-               elog "need to perform a full discharge/charge cycle.  For more"
-               elog "details, please see the pbbuttonsd man page."
-               elog
-       fi
-
-       elog "A script is now available to reset your wirless connection on resume."
-       elog "Simply uncomment the commented command and set the correct device to"
-       elog "use it.  You can find the script in /etc/power/resume.d/wireless"
-
-}
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r4.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r4.ebuild
deleted file mode 100644 (file)
index a1941b1..0000000
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit autotools flag-o-matic eutils
-
-DESCRIPTION="Handles power management and special keys on laptops"
-HOMEPAGE="http://pbbuttons.berlios.de"
-SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="acpi alsa debug doc ibam macbook oss"
-
-DEPEND="macbook? (
-                       sys-libs/libsmbios
-                       sys-apps/pciutils
-               )
-               >=dev-libs/glib-2.6
-               doc? ( app-doc/doxygen )"
-RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
-                >=dev-libs/glib-2.6"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       epatch "${FILESDIR}/${PN}-0.8.1-pmcs.patch"
-       ### Don't link with g++ if we don't use ibam
-       if ! use ibam; then
-               epatch "${FILESDIR}/${PN}-0.8.1-g++.patch"
-       fi
-       ### Fix macbook -lz issue
-       epatch "${FILESDIR}/${PN}-0.8.1-lz.patch"
-       epatch "${FILESDIR}/${PN}-0.8.1-lm.patch"
-       ### Fix new apple hid fnmode issue
-       epatch "${FILESDIR}/${PN}-0.8.1-fnmode.patch"
-       ### Add kernel 2.6.x stuff for 3.x as well
-       epatch "${FILESDIR}/${PN}-0.8.1-laptopmode.sh.patch"
-       epatch "${FILESDIR}/${PN}-0.8.1-cpufreq.patch"
-
-       eautoconf
-}
-
-src_compile() {
-       # Fix crash bug on some systems
-       replace-flags -O? -O1
-
-       if use macbook; then
-               laptop=macbook
-       elif use x86 || use amd64; then
-               if use acpi; then
-                       laptop=acpi
-               else
-                       laptop=i386
-               fi
-       # Default to PowerBook
-       else
-               laptop=powerbook
-       fi
-
-       econf laptop=$laptop \
-               $(use_enable debug) \
-               $(use_with doc doxygen_docs) \
-               $(use_with alsa) \
-               $(use_with oss) \
-               $(use_with ibam) \
-               || die "Sorry, failed to configure pbbuttonsd"
-
-       # Thanks to Stefan Bruda for this workaround
-       # Using -j1 fixes a parallel build issue with the docs
-       if use doc; then
-               emake -j1 || die "Sorry, failed to compile pbbuttonsd"
-       else
-               emake || die "Sorry, failed to compile pbbuttonsd"
-       fi
-}
-
-src_install() {
-       dodir /etc/power
-       use ibam && dodir /var/lib/ibam
-       make DESTDIR="${D}" install || die "failed to install"
-       newinitd "${FILESDIR}/pbbuttonsd.rc6" pbbuttonsd
-       dodoc README
-       use doc && dohtml -r doc/*
-
-       dodir /etc/power/resume.d
-       dodir /etc/power/suspend.d
-       dodir /etc/power/scripts.d
-       exeinto "/etc/power/scripts.d"
-       doexe "${FILESDIR}/wireless"
-       ln -s "${D}/etc/power/scripts.d/wireless" "${D}/etc/power/resume.d/wireless"
-}
-
-pkg_postinst() {
-       if [ -e /etc/pbbuttonsd.conf ]; then
-               ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
-               ewarn "file (/etc/pbbuttonsd.conf) and a new format.  Please check the"
-               ewarn "manual page with 'man pbbuttonsd.cnf' for details."
-               ewarn
-       fi
-
-       if use macbook; then
-               ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
-               ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
-               ewarn "will not work and pbbuttonsd may segfault."
-       fi
-
-       ewarn "Ensure that the evdev kernel module is loaded otherwise"
-       ewarn "pbbuttonsd won't work.  SysV IPC is also required."
-       ewarn
-       ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
-       ewarn "input from one user.  You can set the userallowed option in"
-       ewarn "/etc/pbbuttonsd.cnf to limit access."
-       ewarn
-
-       if use ibam; then
-               elog "To properly initialize the IBaM battery database, you will"
-               elog "need to perform a full discharge/charge cycle.  For more"
-               elog "details, please see the pbbuttonsd man page."
-               elog
-       fi
-
-       elog "A script is now available to reset your wirless connection on resume."
-       elog "Simply uncomment the commented command and set the correct device to"
-       elog "use it.  You can find the script in /etc/power/resume.d/wireless"
-
-}