dev-embedded/sunxi-tools: Version bump to 1.3; all ebuild work by Alexander Nigl...
authorTony Vroon <chainsaw@gentoo.org>
Wed, 13 Jul 2016 09:39:30 +0000 (10:39 +0100)
committerTony Vroon <chainsaw@gentoo.org>
Wed, 13 Jul 2016 09:39:30 +0000 (10:39 +0100)
dev-embedded/sunxi-tools/sunxi-tools-1.3.ebuild [new file with mode: 0644]

diff --git a/dev-embedded/sunxi-tools/sunxi-tools-1.3.ebuild b/dev-embedded/sunxi-tools/sunxi-tools-1.3.ebuild
new file mode 100644 (file)
index 0000000..6d6d13c
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils toolchain-funcs
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz"
+
+DESCRIPTION="Tools for Allwinner A10 devices."
+HOMEPAGE="http://linux-sunxi.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="virtual/libusb"
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
+}
+
+src_install() {
+       dobin bin2fex fex2bin phoenix_info
+       newbin sunxi-bootinfo bootinfo
+       newbin sunxi-fel fel
+       newbin sunxi-fexc fexc
+       newbin sunxi-nand-part nand-part
+       newbin sunxi-pio pio
+}