net-irc/limnoria: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Tue, 11 Feb 2020 12:04:59 +0000 (13:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 11 Feb 2020 12:16:15 +0000 (13:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-irc/limnoria/limnoria-20191123.ebuild
net-irc/limnoria/limnoria-99999999.ebuild

index 87f53168aaae937cfc55bf3b37bed26f5e509ef9..77d3858ab954611c2677c873234d6369f14ccb91 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
 
 inherit distutils-r1
 
@@ -25,7 +25,7 @@ DESCRIPTION="Python based extensible IRC infobot and channel bot"
 HOMEPAGE="https://supybot.aperio.fr/"
 LICENSE="BSD"
 SLOT="0"
-IUSE="crypt ssl test"
+IUSE="crypt ssl"
 
 RDEPEND="
        dev-python/chardet[${PYTHON_USEDEP}]
@@ -40,10 +40,7 @@ RDEPEND="
        !net-irc/supybot
        !net-irc/supybot-plugins
        "
-DEPEND="${RDEPEND}
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-RESTRICT="!test? ( test )"
+DEPEND="${RDEPEND}"
 
 src_unpack() {
        if [[ ${PV} == "99999999" ]]; then
index 87f53168aaae937cfc55bf3b37bed26f5e509ef9..77d3858ab954611c2677c873234d6369f14ccb91 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
 
 inherit distutils-r1
 
@@ -25,7 +25,7 @@ DESCRIPTION="Python based extensible IRC infobot and channel bot"
 HOMEPAGE="https://supybot.aperio.fr/"
 LICENSE="BSD"
 SLOT="0"
-IUSE="crypt ssl test"
+IUSE="crypt ssl"
 
 RDEPEND="
        dev-python/chardet[${PYTHON_USEDEP}]
@@ -40,10 +40,7 @@ RDEPEND="
        !net-irc/supybot
        !net-irc/supybot-plugins
        "
-DEPEND="${RDEPEND}
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-RESTRICT="!test? ( test )"
+DEPEND="${RDEPEND}"
 
 src_unpack() {
        if [[ ${PV} == "99999999" ]]; then