net-vpn/networkmanager-fortisslvpn: disable legacy libnm-glib compat
authorMart Raudsepp <leio@gentoo.org>
Sun, 19 Apr 2020 18:13:54 +0000 (21:13 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 19 Apr 2020 18:14:14 +0000 (21:14 +0300)
Disable libnm-glib, libnm-glib-vpn and libnm-util usage, as they are
all gone with newer NetworkManager.
This also disables libnm-gtk usage, which requires libnm-glib in turn
as well, and is also gone with newer nm-applet.
Depend on new libnma package instead of nm-applet, as this is what
is needed here.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-vpn/networkmanager-fortisslvpn/networkmanager-fortisslvpn-1.2.8-r2.ebuild [new file with mode: 0644]

diff --git a/net-vpn/networkmanager-fortisslvpn/networkmanager-fortisslvpn-1.2.8-r2.ebuild b/net-vpn/networkmanager-fortisslvpn/networkmanager-fortisslvpn-1.2.8-r2.ebuild
new file mode 100644 (file)
index 0000000..e66f115
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="NetworkManager-${PN##*-}"
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="NetworkManager Fortinet SSLVPN compatible plugin"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtk"
+
+RDEPEND="
+       >=net-misc/networkmanager-1.2:=
+       >=dev-libs/glib-2.32:2
+       net-dialup/ppp:=
+       >=net-vpn/openfortivpn-1.2.0
+       gtk? (
+               >=app-crypt/libsecret-0.18
+               >=net-libs/libnma-1.2.0
+               >=x11-libs/gtk+-3.4:3
+       )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       sys-devel/gettext
+       >=dev-util/intltool-0.35
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               --with-dist-version=Gentoo \
+               --localstatedir=/var \
+               $(use_with gtk gnome) \
+               --without-libnm-glib
+}