sys-power/acpi_call: fix qa warning on live
authorConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 15:51:47 +0000 (17:51 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 16:22:12 +0000 (18:22 +0200)
Also bumpe to EAPI=7.

Bug: https://bugs.gentoo.org/694400
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-power/acpi_call/acpi_call-9999.ebuild

index 8eddd39e1548e1c2d8d4b6508d845daec946daef..ba87b06a3dcfae804b7371f0662de9df3e363d3e 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit linux-info linux-mod
 
@@ -11,7 +11,6 @@ if [ "${PV}" = "9999" ]; then
        EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
        KEYWORDS=""
 else
-       inherit vcs-snapshot
        SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64"
 fi
@@ -20,11 +19,10 @@ DESCRIPTION="A kernel module that enables you to call ACPI methods"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE=""
 
+BUILD_TARGETS="default"
 CONFIG_CHECK="ACPI"
 MODULE_NAMES="acpi_call(misc:${S})"
-BUILD_TARGETS="default"
 
 src_compile() {
        BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"