app-crypt/jitterentropy-rngd: added openrc file
authorToralf Förster <toralf@gentoo.de>
Tue, 7 Apr 2020 18:17:39 +0000 (20:17 +0200)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 11 Apr 2020 01:05:29 +0000 (20:05 -0500)
Signed-off-by: Toralf Förster <toralf@gentoo.de>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd [new file with mode: 0755]
app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild

diff --git a/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-initd
new file mode 100755 (executable)
index 0000000..1a7fb84
--- /dev/null
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="jitterentropy daemon"
+command="/usr/sbin/jitterentropy-rngd"
+pidfile="/run/jitterentropy-rngd.pid"
+command_args="--pid ${pidfile}"
+
+depend() {
+   need localmount
+   before net
+   use logger
+
+   provide entropy
+}
+
index bd3a671e48d484b0621f5818d62213a4509d3206..a0f57561d71cbcbbd801798dc096f0e936969738 100644 (file)
@@ -21,4 +21,6 @@ PATCHES=(
 src_install() {
        emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
                UNITDIR="$(systemd_get_systemunitdir)" install
+       newinitd "${FILESDIR}"/jitterentropy-rngd-initd jitterentropy-rngd
 }
+