x11-terms/xfce4-terminal: Bump to 0.8.9.2
authorMichał Górny <mgorny@gentoo.org>
Mon, 30 Mar 2020 06:31:43 +0000 (08:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 30 Mar 2020 06:51:01 +0000 (08:51 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-terms/xfce4-terminal/Manifest
x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild [new file with mode: 0644]

index f79177d3eb683a54f7becb1a3912e86663c5688a..ff634ad6852902ca1d86c91fd79594059ce6295a 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-terminal-0.8.9.1.tar.bz2 943603 BLAKE2B ba8521c2e80e8979f1585eb5d9696c31c057a6ae1a9f468c8fe2e97f3a4fa5d494648b349b6c75a115918492d1b46177cf23d712d92345cab74551d68e054ea4 SHA512 c1a68300604d1db205ac52b51dfea38031dfd92b31f7530705ac6bc875c9b4f9819bdf05bca23cbfddd87f7899488ee4dab4c897ceb96efc41a44acfc298ed22
+DIST xfce4-terminal-0.8.9.2.tar.bz2 945176 BLAKE2B a37a665601c5bdb2f53cd62a0909befaabd9bca0747d477fe369f4e325be15a362d249ae675e6cf707ecc89e623b4b1d73f7a31d32f6c6fcc13e4c57684f5d4b SHA512 1402d913bcc0c050b6c83405c754cdec71cf9bb56e2e68e4396d7ce48bec6e1b0cc875ea3ea2f7a0dff8280d306519fd74a8f9d9ebca383a8f295991cb9ddd94
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.9.2.ebuild
new file mode 100644 (file)
index 0000000..81501fe
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="https://docs.xfce.org/apps/terminal/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter"
+
+RDEPEND=">=dev-libs/glib-2.38:2=
+       >=x11-libs/gtk+-3.20.8:3=
+       x11-libs/libX11:=
+       >=x11-libs/vte-0.38:2.91=
+       >=xfce-base/libxfce4ui-4.10:=[gtk3(+)]
+       utempter? ( sys-libs/libutempter:= )"
+DEPEND="${RDEPEND}
+       dev-libs/libxml2
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS )
+
+src_configure() {
+       local myconf=(
+               $(use_with utempter)
+       )
+
+       econf "${myconf[@]}"
+}