games-strategy/warzone2100: Bump to version 3.3.0_beta1
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 1 Aug 2019 03:17:18 +0000 (05:17 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 1 Aug 2019 03:25:55 +0000 (05:25 +0200)
Closes: https://bugs.gentoo.org/691202
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-strategy/warzone2100/Manifest
games-strategy/warzone2100/files/warzone2100-3.3.0_beta1-gettext_version.patch [new file with mode: 0644]
games-strategy/warzone2100/warzone2100-3.3.0_beta1.ebuild [new file with mode: 0644]

index bb5b63ad59303e9dbb0326f7f3ab19ce333b8725..426b447104e7503941b1bf5d7ec2e580b89636f4 100644 (file)
@@ -1,3 +1,4 @@
 DIST warzone2100-3.2.3-qt_compile_fix.patch 680 BLAKE2B 1073ea1619640455326c63dc55bf031579c8e9cb0b1b159e4fb1f9e8aa63bfcc6985e91cb2667149e7cc4b354bf96726fc6b8f8a8f519375e0a88c4be21dcb69 SHA512 766698c25c02b4254424efdafb8aa7b37360c3c05d3cd2d6c7f9127cbdd6a25840f98e8e3aadd5d6af494b4632584e564214c1f20c0bd74eb637da305552e067
 DIST warzone2100-3.2.3.tar.xz 81314060 BLAKE2B 231be8c24d1c0967adb0a76ac9e441c2ea9f835720df9951f74227988473d100b24bccbfe4b5882a36c63a798368ed1a1f871751b6b363d90a82fea48c44ba65 SHA512 4b1bc0a0bb50a8b4726a2762a922ee233b92f9835e38bbab80c159a9cb301df7434a73ba5acfb17404031467c02a9b3480d6a0d44906d70896311b3468141746
+DIST warzone2100-3.3.0_beta1.tar.xz 85916776 BLAKE2B ec94e6fafff103e014e063f554b6a40411577d9c415733eb7857c4cd470195f1ab9878c2d5afd6c154e1f058c2f2a645a46738518d307da42ae97e0898fdf75a SHA512 17e9d81e7eadc71ad285147ff76517a92e8ea8747a05a6a08373d994725efa6bae11f87cd6bc9068cbfd78aa24d26fea95929c65a0906d03605b96469d972f4a
 DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
diff --git a/games-strategy/warzone2100/files/warzone2100-3.3.0_beta1-gettext_version.patch b/games-strategy/warzone2100/files/warzone2100-3.3.0_beta1-gettext_version.patch
new file mode 100644 (file)
index 0000000..2d4b6c5
--- /dev/null
@@ -0,0 +1,36 @@
+From 5539b080824bd4bcd0f212829012993ef193dc41 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 1 Aug 2019 04:53:14 +0200
+Subject: [PATCH] configure.ac: Raise AM_GNU_GETTEXT_VERSION to 0.17
+
+the shipped copy of po/Makefile.in.in comes from gettext-0.17 and since
+m4/po.m4 has been changed to use AC_PROG_MKDIR_P (Trac ticket #4701)
+autopoint from gettext would produce a broken po/Makefile.in.in which has
+no MKDIR_P definition. This again would result in "make install" throwing
+the following error when invoking install-data-yes target in /po/ dir:
+
+  make[1]: execvp: /usr/share: Permission denied
+
+Raising AM_GNU_GETTEXT_VERSION fixes the described issue.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7e9c31433..30a732447 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -71,7 +71,7 @@ AC_CHECK_HEADERS(alloca.h sys/ucontext.h)
+ # Check for gettext
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.15])
++AM_GNU_GETTEXT_VERSION([0.17])
+ # Check for pkg-config
+ PKG_PROG_PKG_CONFIG
+-- 
+2.22.0
+
diff --git a/games-strategy/warzone2100/warzone2100-3.3.0_beta1.ebuild b/games-strategy/warzone2100/warzone2100-3.3.0_beta1.ebuild
new file mode 100644 (file)
index 0000000..fddc090
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs xdg
+
+MY_PV=$(ver_cut 1-2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.xz
+       videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain"
+SLOT="0"
+#[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~amd64 ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+# TODO: unbundle miniupnpc and quesoglc
+# quesoglc-0.7.2 is buggy: http://developer.wz2100.net/ticket/2828
+CDEPEND="
+       >=dev-games/physfs-2[zip]
+       dev-libs/openssl:0=
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtopengl:5
+       dev-qt/qtscript:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       media-libs/freetype:2
+       media-libs/glew:=
+       media-libs/harfbuzz
+       media-libs/libogg
+       media-libs/libpng:0
+       media-libs/libsdl2[opengl,video,X]
+       media-libs/libtheora
+       media-libs/libvorbis
+       media-libs/openal
+       sys-libs/zlib
+       virtual/glu
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libXrandr
+       nls? ( virtual/libintl )
+"
+DEPEND="
+       ${CDEPEND}
+       dev-libs/fribidi
+       media-libs/fontconfig
+"
+RDEPEND="
+       ${CDEPEND}
+       media-fonts/dejavu
+"
+BDEPEND="
+       app-arch/zip
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.3.0_beta1-gettext_version.patch
+)
+
+src_prepare() {
+       default
+
+       sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
+       sed '/appdata\.xml/d' -i icons/Makefile.am || die
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --localedir="${EPREFIX}"/usr/share/locale
+               --with-distributor="Gentoo ${PF}"
+               --with-icondir="${EPREFIX}"/usr/share/icons/hicolor/128x128/apps
+               --with-applicationdir="${EPREFIX}"/usr/share/applications
+               $(use_enable debug debug relaxed)
+               $(use_enable nls)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       emake AR="$(tc-getAR)"
+}
+
+src_install() {
+       local HTML_DOCS=( doc/quickstartguide.html )
+       default
+       rm "${ED}"/usr/share/doc/${PF}/COPYING* || die
+       if use videos ; then
+               insinto /usr/share/${PN}
+               newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
+       fi
+       doman doc/warzone2100.6
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}