games-simulation/openttd: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Apr 2019 12:23:00 +0000 (14:23 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Apr 2019 12:23:00 +0000 (14:23 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-simulation/openttd/Manifest
games-simulation/openttd/files/openttd.initd [deleted file]
games-simulation/openttd/openttd-1.7.1-r1.ebuild [deleted file]
games-simulation/openttd/openttd-1.7.2.ebuild [deleted file]

index bf1c8e1257c889813c71d7b2c11172d345b1908d..8bae6409e8bc8f151e884142d6d17f2e91fcdf3d 100644 (file)
@@ -1,4 +1,2 @@
-DIST openttd-1.7.1-source.tar.gz 10090311 BLAKE2B 339171cd2895398ee1fedcfd24d1126fbc060b6d4530b267310b3f220448f8e6469a726e71e9882bea117585ea7b9f7271205f576ee2b26de6dec079f57f1620 SHA512 4a0d2ee424374b50fe0d089b86ff16b5de3159848a38143ca6745e349b6126567f1e4beda9afe2e6bc21ffffce1166acf719d3f5c95703a14c1379f8857e83d3
-DIST openttd-1.7.2-source.tar.gz 10097175 BLAKE2B a027b6ca6d3116dc3e6ad6ae43965682107268e367032418200cf1c1e16c5b5dad39c275ea57d923f17564d80cceb0e9909dc5aaf7ee230242f0ce0f46f06b1a SHA512 44d25061c42cb9c81baa67a40ff31a6681dcbb121c61db74c5179a31f189919471a82b7fd3f79c2cdeef02af5b47ec35fdbdc7feed74ca2360c028869fe772e8
 DIST openttd-1.8.0-source.tar.xz 6521016 BLAKE2B b3a608fd21d21f861af6eba235c028a59f071ab4698cfdcdd499b6ea7ece853679b064935368d95330414a24ac90aaa3c426afc12a2e135d5b0a48170879b807 SHA512 a2d61b3c94a550c8f3a581127df8c3459b1ddff5ba924942c468cbc70e88e0bf4405cecb68a91243b544ead64f215aa8d489a07b38dce507ae7d59e8ec155d7a
 DIST openttd-1.9.0-source.tar.xz 6575956 BLAKE2B 31d663b2f8aa67d9e3eb7899795468e8641671bb977957fdc6e55c8dedf3f2a00757de67ed034bf6180cc6091006a1b0bfba8af22d09744eb839a54ca662cbd9 SHA512 fcc044ea93810c99e9b3e80676676272c6f0efb43faa7ef4bfa7184aea793680df22504a1831837cc5ae8481e898d0636b992d1ddb8560cd4848463343adba2d
diff --git a/games-simulation/openttd/files/openttd.initd b/games-simulation/openttd/files/openttd.initd
deleted file mode 100644 (file)
index 7a71958..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-depend() {
-       need net
-}
-
-start() {
-       ebegin "Starting OpenTTD dedicated server"
-       start-stop-daemon --start -q --exec /usr/games/bin/openttd -- -D -f > /dev/null
-       eend $?
-}
-
-stop() {
-       ebegin "Stopping OpenTTD dedicated server"
-       start-stop-daemon --stop -q -n openttd
-       eend $?
-}
diff --git a/games-simulation/openttd/openttd-1.7.1-r1.ebuild b/games-simulation/openttd/openttd-1.7.1-r1.ebuild
deleted file mode 100644 (file)
index f243020..0000000
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
-RESTRICT="test" # needs a graphics set in order to test
-
-RDEPEND="!dedicated? (
-               media-libs/libsdl[sound,X,video]
-               icu? (
-                       dev-libs/icu-layoutex
-                       dev-libs/icu-le-hb
-                       >=dev-libs/icu-58.1:=
-               )
-               truetype? (
-                       media-libs/fontconfig
-                       media-libs/freetype:2
-                       sys-libs/zlib
-               )
-       )
-       lzo? ( dev-libs/lzo:2 )
-       iconv? ( virtual/libiconv )
-       png? ( media-libs/libpng:0 )
-       zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-PDEPEND="
-       !dedicated? (
-               openmedia? (
-                       games-misc/openmsx
-                       games-misc/opensfx
-               )
-               aplaymidi? ( media-sound/alsa-utils )
-               !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
-       )
-       openmedia? ( >=games-misc/opengfx-0.4.7 )"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.6.0-cflags.patch
-)
-
-src_configure() {
-       local myopts=()
-       # there is an allegro interface available as well as sdl, but
-       # the configure for it looks broken so the sdl interface is
-       # always built instead.
-       local myopts+=( --without-allegro )
-
-       # libtimidity not needed except for some embedded platform
-       # nevertheless, it will be automagically linked if it is
-       # installed. Hence, we disable it.
-       myopts+=( --without-libtimidity )
-
-       use debug && myopts+=( --enable-debug=3 )
-
-       if use dedicated ; then
-               myopts+=( --enable-dedicated )
-       else
-               use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
-               myopts+=(
-                       $(use_with truetype freetype)
-                       $(use_with icu)
-                       --with-sdl
-               )
-       fi
-       if use png || { use !dedicated && use truetype; } || use zlib ; then
-               myopts+=( --with-zlib )
-       else
-               myopts+=( --without-zlib )
-       fi
-
-       # configure is a hand-written bash-script, so econf will not work.
-       # It's all built as C++, upstream uses CFLAGS internally.
-       CFLAGS="" ./configure \
-               --disable-strip \
-               --prefix-dir="${EPREFIX%/}/usr" \
-               --binary-dir="bin" \
-               --install-dir="${D}" \
-               --menu-group="Game;Simulation;" \
-               ${myopts[@]} \
-               $(use_with iconv) \
-               $(use_with png) \
-               $(use_with cpu_flags_x86_sse sse) \
-               $(use_with lzo liblzo2) \
-               || die
-}
-
-src_compile() {
-       emake VERBOSE=1
-}
-
-src_install() {
-       default
-       if use dedicated ; then
-               newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
-               rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
-       fi
-       rm -f "${ED}"/usr/share/doc/${PF}/COPYING
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-
-       if ! use lzo ; then
-               elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
-               elog "required, disabling it does mean that loading old savegames"
-               elog "or scenarios from ancient versions (~0.2) will fail."
-               elog
-       fi
-
-       if use dedicated ; then
-               ewarn "Warning: The init script will kill all running openttd"
-               ewarn "processes when triggered, including any running client sessions!"
-       else
-               if use aplaymidi ; then
-                       elog "You have emerged with 'aplaymidi' for playing MIDI."
-                       elog "This option is for those with a hardware midi device,"
-                       elog "or who have set up ALSA to handle midi ports."
-                       elog "You must set the environment variable ALSA_OUTPUT_PORTS."
-                       elog "Available ports can be listed by using 'aplaymidi -l'."
-               else
-                       if ! use timidity ; then
-                               elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
-                               elog "in USE. Music may or may not work in-game. If you happen"
-                               elog "to have timidity++ installed, music will work so long"
-                               elog "as it remains installed, but OpenTTD will not depend on it."
-                       fi
-               fi
-               if ! use openmedia ; then
-                       elog
-                       elog "OpenTTD was compiled without the 'openmedia' USE flag."
-                       elog
-                       elog "In order to play, you must at least install:"
-                       elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
-                       elog "following 6 files from a version of Transport Tycoon Deluxe"
-                       elog "(windows or DOS) to ~/.openttd/data/ or"
-                       elog "${GAMES_DATADIR}/${PN}/data/."
-                       elog
-                       elog "From the WINDOWS version you need: "
-                       elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
-                       elog "OR from the DOS version you need: "
-                       elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
-                       elog
-                       elog "File names are case sensitive, but should work either with"
-                       elog "all upper or all lower case names"
-                       elog
-                       elog "In addition, in-game music will be unavailable: for music,"
-                       elog "install games-misc/openmsx, or use the in-game download"
-                       elog "functionality to get a music set"
-                       elog
-               fi
-       fi
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}
diff --git a/games-simulation/openttd/openttd-1.7.2.ebuild b/games-simulation/openttd/openttd-1.7.2.ebuild
deleted file mode 100644 (file)
index f6e90e9..0000000
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
-RESTRICT="test" # needs a graphics set in order to test
-
-RDEPEND="!dedicated? (
-               media-libs/libsdl[sound,X,video]
-               icu? (
-                       dev-libs/icu-layoutex
-                       dev-libs/icu-le-hb
-                       >=dev-libs/icu-58.1:=
-               )
-               truetype? (
-                       media-libs/fontconfig
-                       media-libs/freetype:2
-                       sys-libs/zlib
-               )
-       )
-       lzo? ( dev-libs/lzo:2 )
-       iconv? ( virtual/libiconv )
-       png? ( media-libs/libpng:0 )
-       zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-PDEPEND="
-       !dedicated? (
-               openmedia? (
-                       games-misc/openmsx
-                       games-misc/opensfx
-               )
-               aplaymidi? ( media-sound/alsa-utils )
-               !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
-       )
-       openmedia? ( >=games-misc/opengfx-0.4.7 )"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.6.0-cflags.patch
-)
-
-src_configure() {
-       local myopts=()
-       # there is an allegro interface available as well as sdl, but
-       # the configure for it looks broken so the sdl interface is
-       # always built instead.
-       local myopts+=( --without-allegro )
-
-       # libtimidity not needed except for some embedded platform
-       # nevertheless, it will be automagically linked if it is
-       # installed. Hence, we disable it.
-       myopts+=( --without-libtimidity )
-
-       use debug && myopts+=( --enable-debug=3 )
-
-       if use dedicated ; then
-               myopts+=( --enable-dedicated )
-       else
-               use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
-               myopts+=(
-                       $(use_with truetype freetype)
-                       $(use_with icu)
-                       --with-sdl
-               )
-       fi
-       if use png || { use !dedicated && use truetype; } || use zlib ; then
-               myopts+=( --with-zlib )
-       else
-               myopts+=( --without-zlib )
-       fi
-
-       # configure is a hand-written bash-script, so econf will not work.
-       # It's all built as C++, upstream uses CFLAGS internally.
-       CFLAGS="" ./configure \
-               --disable-strip \
-               --prefix-dir="${EPREFIX%/}/usr" \
-               --binary-dir="bin" \
-               --install-dir="${D}" \
-               --menu-group="Game;Simulation;" \
-               ${myopts[@]} \
-               $(use_with iconv) \
-               $(use_with png) \
-               $(use_with cpu_flags_x86_sse sse) \
-               $(use_with lzo liblzo2) \
-               || die
-}
-
-src_compile() {
-       emake VERBOSE=1
-}
-
-src_install() {
-       default
-       if use dedicated ; then
-               newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
-               rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
-       fi
-       rm -f "${ED}"/usr/share/doc/${PF}/COPYING
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-
-       if ! use lzo ; then
-               elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
-               elog "required, disabling it does mean that loading old savegames"
-               elog "or scenarios from ancient versions (~0.2) will fail."
-               elog
-       fi
-
-       if use dedicated ; then
-               ewarn "Warning: The init script will kill all running openttd"
-               ewarn "processes when triggered, including any running client sessions!"
-       else
-               if use aplaymidi ; then
-                       elog "You have emerged with 'aplaymidi' for playing MIDI."
-                       elog "This option is for those with a hardware midi device,"
-                       elog "or who have set up ALSA to handle midi ports."
-                       elog "You must set the environment variable ALSA_OUTPUT_PORTS."
-                       elog "Available ports can be listed by using 'aplaymidi -l'."
-               else
-                       if ! use timidity ; then
-                               elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
-                               elog "in USE. Music may or may not work in-game. If you happen"
-                               elog "to have timidity++ installed, music will work so long"
-                               elog "as it remains installed, but OpenTTD will not depend on it."
-                       fi
-               fi
-               if ! use openmedia ; then
-                       elog
-                       elog "OpenTTD was compiled without the 'openmedia' USE flag."
-                       elog
-                       elog "In order to play, you must at least install:"
-                       elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
-                       elog "following 6 files from a version of Transport Tycoon Deluxe"
-                       elog "(windows or DOS) to ~/.openttd/data/ or"
-                       elog "${GAMES_DATADIR}/${PN}/data/."
-                       elog
-                       elog "From the WINDOWS version you need: "
-                       elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
-                       elog "OR from the DOS version you need: "
-                       elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
-                       elog
-                       elog "File names are case sensitive, but should work either with"
-                       elog "all upper or all lower case names"
-                       elog
-                       elog "In addition, in-game music will be unavailable: for music,"
-                       elog "install games-misc/openmsx, or use the in-game download"
-                       elog "functionality to get a music set"
-                       elog
-               fi
-       fi
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}