app-backup/backintime: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 08:52:24 +0000 (09:52 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 09:08:31 +0000 (10:08 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-backup/backintime/backintime-1.2.1.ebuild
app-backup/backintime/backintime-9999.ebuild

index c7bc7578f634f3883cbdd84b97a26326936fe9e1..754fca5ac5f67f2aed16e586cbfc17c2a34ed1e6 100644 (file)
@@ -19,8 +19,10 @@ IUSE="examples qt5"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 DEPEND="${PYTHON_DEPS}
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       dev-python/keyring[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+               dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+       ')
        net-misc/openssh
        net-misc/rsync[xattr,acl]
 "
index fc293b01096b74a0fa41c76dbd5424b2ea9d09c6..d243f64edfdea21cee6b1d1779f4f06b5fede803 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -19,8 +19,10 @@ IUSE="examples qt5"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 DEPEND="${PYTHON_DEPS}
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       dev-python/keyring[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+               dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+       ')
        net-misc/openssh
        net-misc/rsync[xattr,acl]
 "