x11-plugins/wmwork: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Wed, 29 Jan 2020 18:00:10 +0000 (19:00 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Wed, 29 Jan 2020 18:26:59 +0000 (19:26 +0100)
Closes: https://bugs.gentoo.org/706688
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmwork/wmwork-0.2.5-r1.ebuild

diff --git a/x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch b/x11-plugins/wmwork/files/wmwork-0.2.5-gcc-10.patch
new file mode 100644 (file)
index 0000000..3ed8b82
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/wmgeneral.c
++++ b/wmgeneral.c
+@@ -45,6 +45,7 @@ Window               iconwin, win;
+ GC                    NormalGC;
+ XpmIcon               wmgen;
+ Pixmap                pixmask;
++Display               *display;
+   /*****************/
+  /* Mouse Regions */
+--- a/wmgeneral.h
++++ b/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+  /* Global variable */
+ /*******************/
+-Display               *display;
++extern Display                *display;
+   /***********************/
+  /* Function Prototypes */
index a7d81d4d1ae40704b756a0041071d0d84b66ff57..e8fd4e681e82f438104613f7f76a411617575ba8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -20,3 +20,4 @@ DEPEND="${RDEPEND}
 S="${WORKDIR}/${P}/src"
 
 DOCS=( ../{CHANGES,README} )
+PATCHES=( ${FILESDIR}/${P}-gcc-10.patch )