x11-misc/xwallpaper: bump to 0.6.5
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 11:34:09 +0000 (04:34 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 12:26:57 +0000 (05:26 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
x11-misc/xwallpaper/Manifest
x11-misc/xwallpaper/xwallpaper-0.6.5.ebuild [new file with mode: 0644]

index 596976f4199b49591338e0650a509be4fbd52c89..444bdd79b08714f059c99ee0ecb1be5c154c152f 100644 (file)
@@ -1,2 +1,3 @@
 DIST xwallpaper-0.6.2.tar.xz 82600 BLAKE2B 2e2b1121fcc2481c4a1e3c78e357534b9609b4435c4364f22dbed78ee0de7c671d2044403c22d22b494a9c89efd17d843f32b296c863df3c0f5d7b3673ae361f SHA512 3713038ffe8fe1da117dc64db6e3c8642fe663473d1e9078963890fa08f21af6ace60e08773e23e6025fcf2116563e24c76d07a66ba02537b38aafa9ac99f395
 DIST xwallpaper-0.6.4.tar.xz 82752 BLAKE2B e81a1a9ec56ffe0a1953f1186c945c9ebb143ff683b8c0c01b819506b79520738935d04725420a24b38119221cbb71d9a5562bffd03e03736c65ba7e3c6a1713 SHA512 531910957c44f7e5ce7357fa46737967f673aeca53868012211eb91507f78bd028f8d84fcbee6e1237107816a09f8247cd0445c0907b60792ff5d07416630d56
+DIST xwallpaper-0.6.5.tar.xz 82696 BLAKE2B 8c12bcce2a2eeb9580038b172b51284cc9fa851f01bef34e7cfeb13ccc05879f5443ef0b7fd39a4f0d5abcc399ec614db28f6f6db6847505855128348fd22d4b SHA512 99c911c6a4f7501101d85532cfb9956fa4affb57f7836e9216e5e0d873ed34c9e7d0a9983def442a4728a682a3351268905e22174dc9a14d003dc36c42ed9615
diff --git a/x11-misc/xwallpaper/xwallpaper-0.6.5.ebuild b/x11-misc/xwallpaper/xwallpaper-0.6.5.ebuild
new file mode 100644 (file)
index 0000000..2b1e161
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+       SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+RDEPEND="
+       x11-libs/pixman
+       x11-libs/xcb-util
+       x11-libs/xcb-util-image
+       jpeg? ( media-libs/libjpeg-turbo:= )
+       png? ( media-libs/libpng:0= )
+       seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+       xpm? ( x11-libs/libXpm )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+src_configure() {
+       local myconf=(
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with seccomp)
+               $(use_with xpm)
+               --with-randr
+       )
+       econf "${myconf[@]}"
+}