net-dialup/accel-ppp: fix detection of Lua interpreter
authorSergey Popov <pinkbyte@gentoo.org>
Sat, 9 May 2020 10:18:02 +0000 (13:18 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Sat, 9 May 2020 10:20:09 +0000 (13:20 +0300)
Reported-by: Toralf Förster <toralf@gentoo.org>
Closes: https://bugs.gentoo.org/720846
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
net-dialup/accel-ppp/accel-ppp-1.12.0.ebuild
net-dialup/accel-ppp/accel-ppp-9999.ebuild

index 7362e06b530ce6d727c981cbf8ddc556d1342de1..61e4c0092c832fee81288b1ffaf2055b2437a26e 100644 (file)
@@ -72,7 +72,7 @@ src_configure() {
                -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
                -DCRYPTO=OPENSSL
                -DLOG_PGSQL="$(usex postgres)"
-               -DLUA="$(usex lua)"
+               -DLUA="$(usex lua TRUE FALSE)"
                -DMEMDEBUG="$(usex debug)"
                -DNETSNMP="$(usex snmp)"
                -DRADIUS="$(usex radius)"
index a05fd2d9a09d746c6335a4d715ce154345262faa..68e1f642d6f6ea0e7720cb98577cbb01a61899aa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -64,7 +64,7 @@ src_configure() {
                -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
                -DCRYPTO=OPENSSL
                -DLOG_PGSQL="$(usex postgres)"
-               -DLUA="$(usex lua)"
+               -DLUA="$(usex lua TRUE FALSE)"
                -DMEMDEBUG="$(usex debug)"
                -DNETSNMP="$(usex snmp)"
                -DRADIUS="$(usex radius)"