app-admin/ps_mem: new snapshot for a few upstream fixes
authorBen Kohler <bkohler@gentoo.org>
Wed, 22 Apr 2020 12:12:39 +0000 (07:12 -0500)
committerBen Kohler <bkohler@gentoo.org>
Wed, 22 Apr 2020 12:13:17 +0000 (07:13 -0500)
* fix error message without linprocfs
* fix shared memory with Linux kernel >= 5.3
* fix missing processes whose commandline isn't executable and parent
  is inaccessible

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
app-admin/ps_mem/Manifest
app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild [new file with mode: 0644]

index f61c651d0a74cd5394ee03d890dcf182f68b2026..8ba529e9e0a9ce6c0b3b1962370490c696e5ffdc 100644 (file)
@@ -1 +1,2 @@
 DIST ps_mem-3.13.tar.gz 18331 BLAKE2B a0689a98597e02a63cc83188e717421bf873b9202c0f524165ffc838fd438c539209c2f4e6561226bda8c6f85364707d29d13519d6d3e53a6d34cb39378d2de1 SHA512 bf5affaede5f052cc878d46ef81186511a1e8f5939cd7e8560ab2df9faf4dc31566cb4172d956cdcf1e6fc5586ba3458ba1011aee3720f6b7eeb3cf40b4f90dc
+DIST ps_mem-3.13_p20200417.tar.gz 18472 BLAKE2B 43e04d0357458107fb25600024243baaec703124fc58a819c011c847a52ad6fb7384ef38a5aa965e3ae88288cca6c76a15819466839eb729a63c4492eaa4ec0d SHA512 9694cec5d696a42dfe2f60dd024f541283e2f52aafb499ee2e551574133262bb0fc4bf6eb0e7075fb1b129aff6cd8fe6968f411f56ee1d31eb6f9aebff2d9852
diff --git a/app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild b/app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild
new file mode 100644 (file)
index 0000000..738db1a
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="fc75a8cc3cda05c53a4ae4fe296deeb9fc43908d"
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/ps_mem"
+SRC_URI="https://github.com/pixelb/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+python_install() {
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       doman ${PN}.1
+}