app-arch/libarchive: Reenable tests
authorMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 09:29:39 +0000 (11:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 09:30:16 +0000 (11:30 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-arch/libarchive/libarchive-3.4.3.ebuild

index 7eb40b6533f052930434ed62934bc6e624a314b8..dde837017a8291aad6bf08562ae32a903a4bfdea 100644 (file)
@@ -41,10 +41,6 @@ PATCHES=(
        "${FILESDIR}"/${PN}-3.3.3-libressl.patch
 )
 
-# Various test problems, starting with the fact that sandbox
-# explodes on long paths. https://bugs.gentoo.org/598806
-RESTRICT="test"
-
 src_prepare() {
        default
        elibtoolize  # is required for Solaris sol2_ld linker fix
@@ -97,9 +93,19 @@ multilib_src_compile() {
        fi
 }
 
+src_test() {
+       mkdir -p "${T}"/bin || die
+       # tests fail when lbzip2[symlink] is used in place of ref bunzip2
+       ln -s "${BROOT}/bin/bunzip2" "${T}"/bin || die
+       local -x PATH=${T}/bin:${PATH}
+       multilib-minimal_src_test
+}
+
 multilib_src_test() {
-       # Replace the default src_test so that it builds tests in parallel
-       multilib_is_native_abi && emake check
+       # sandbox is breaking long symlink behavior
+       local -x SANDBOX_ON=0
+       local -x LD_PRELOAD=
+       emake check
 }
 
 multilib_src_install() {