sys-apps/inxi: Version bump to 3.0.36-1
authorJonas Stein <jstein@gentoo.org>
Thu, 26 Sep 2019 20:54:07 +0000 (22:54 +0200)
committerJonas Stein <jstein@gentoo.org>
Thu, 26 Sep 2019 20:55:25 +0000 (22:55 +0200)
Bump to 3.0.36-1

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jonas Stein <jstein@gentoo.org>
sys-apps/inxi/Manifest
sys-apps/inxi/inxi-3.0.36.1.ebuild [new file with mode: 0644]

index 67e3a2df5798b2817bad80eae9e114a39eedab5d..299ea9b4ceb052d3b176cbc7a716537b985167dc 100644 (file)
@@ -1,2 +1,3 @@
 DIST inxi-3.0.33.1.tar.gz 306370 BLAKE2B 9ebd8d6e00fe241d5fdf52ddbfc01bdb03682f10baf79cf600a4ad94d36870cd5676fb74cbaebd5edfe9288df3c8f649e4f99dd6bbcd12681663423554f74114 SHA512 7239920311e8066f08a6d81525f3608bb555d229bc4f9e33d45442cef4ee219266bdd7c4a7a25de386db8079d1ef496e3fc22620ada772ce6a51c04cb7023256
 DIST inxi-3.0.34.1.tar.gz 308373 BLAKE2B 290a0887a7885b040f614140a99cbd7e0a8f8b89943e2f39cf00f033fb88fbe6a65dd4b5848f4ff7758f5fe81112404abef6102c44f4732308cda0e4ce887766 SHA512 cfc221ce5cd87dd2418ef0a6f916b17ed4a90aa9c6485ffc40a37d87d337f18d1ad98ae53fa366dc56b5250f2e95dc14c528b14d8f796b6d1b26b982cbf0b22b
+DIST inxi-3.0.36.1.tar.gz 311680 BLAKE2B 95c9ab57a9af50ace8fdacebb42a94017b1506a9215f8f70ff35f281dd207685d570fe257abc5446b57dd9b9a7ce28e568a4ebf9d664731dde437a6cfd64647f SHA512 1b242878b9a5180ed63dedcac7381ce41380a1bd95ba7f85bfb2c97b635fdc7700162373078963ef708fa5cd47084aa6f5c71b212042fe1acd87e01a85599296
diff --git a/sys-apps/inxi/inxi-3.0.36.1.ebuild b/sys-apps/inxi/inxi-3.0.36.1.ebuild
new file mode 100644 (file)
index 0000000..4a987ea
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+       sys-apps/pciutils
+       sys-apps/usbutils
+       bluetooth? ( net-wireless/bluez )
+       hddtemp? ( app-admin/hddtemp )
+       opengl? ( x11-apps/mesa-progs )
+       "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+       dobin ${PN}
+       doman ${PN}.1
+}
+
+pkg_postinst() {
+       elog "Some features of inxi depend on additional packages. Get a full list with"
+       elog "inxi --recommends"
+}