app-shells/fzy: update live ebuild
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 02:19:58 +0000 (19:19 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 25 Apr 2020 02:21:39 +0000 (19:21 -0700)
Bug: https://bugs.gentoo.org/719072
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
app-shells/fzy/fzy-9999.ebuild

index 8fb7bb35ba126318b4a81ac3b37f96d63859c9ff..98dfd31e607d717ee7ec1bb9700934e6bf49b207 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit eutils savedconfig toolchain-funcs
 
@@ -21,12 +21,11 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-PATCHES=( "${FILESDIR}"/fzy-0.9-cflags.patch )
-
 src_prepare() {
        default
        restore_config config.h
        tc-export CC
+       sed -i 's/$(LIBS)/$(LIBS) $(LDFLAGS)/g' Makefile || die
 }
 
 src_install() {