dev-util/astyle: Respect CXX wrt bug 622068
authorDaniel Campbell <zlg@gentoo.org>
Fri, 23 Jun 2017 19:38:09 +0000 (12:38 -0700)
committerDaniel Campbell <zlg@gentoo.org>
Fri, 23 Jun 2017 19:38:53 +0000 (12:38 -0700)
Thanks to mgorny for finding the issue.

Gentoo-Bug: 622068
Gentoo-Bug-URL: https://bugs.gentoo.org/622068
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-util/astyle/astyle-3.0.1.ebuild
dev-util/astyle/astyle-3.0.ebuild

index e32b6189e88704496cb64aa6eafbf5ae190876cf..91f94429fc53e863958aa96bb658764132b345d3 100644 (file)
@@ -38,7 +38,8 @@ src_configure() {
 }
 
 src_compile() {
-       emake -f ../build/gcc/Makefile -C src \
+       # ../build/clang/Makefile is identical except for CXX line.
+       emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
                ${PN} \
                shared \
                $(usev java) \
index 4392d25b3dfd0e72724cd52dee57776bc342a525..85544bdc8bb1fd9bc65fb06e86ad6f83653ae2da 100644 (file)
@@ -38,7 +38,8 @@ src_configure() {
 }
 
 src_compile() {
-       emake -f ../build/gcc/Makefile -C src \
+       # ../build/clang/Makefile is identical except for CXX line.
+       emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
                ${PN} \
                shared \
                $(usev java) \