sci-physics/root: remove nosplash USE flag from live ebuild
authorGuilherme Amadio <amadio@gentoo.org>
Mon, 19 Aug 2019 13:56:28 +0000 (15:56 +0200)
committerGuilherme Amadio <amadio@gentoo.org>
Tue, 20 Aug 2019 06:33:09 +0000 (08:33 +0200)
This is now the default upstream.

Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
sci-physics/root/root-9999.ebuild

index 0b58a32c0138ae8fd6fe06d43ee198504d7180d1..e841fafab73c177ecbbaca715a368a7e311d35ed 100644 (file)
@@ -16,9 +16,9 @@ HOMEPAGE="https://root.cern"
 
 IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
        +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
-       mysql nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
-       +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva
-       +unuran vc vmc +xml xrootd"
+       mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
+       qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
+       vmc +xml xrootd"
 
 if [[ ${PV} =~ "9999" ]] ; then
        inherit git-r3
@@ -136,10 +136,6 @@ src_prepare() {
 
        # CSS should use local images
        sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
-
-       if use nosplash; then
-               sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
-       fi
 }
 
 # Note: ROOT uses bundled clang because it is patched and API-incompatible