sys-kernel/pf-sources: bump to 5.6-pf5
authorJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 14:34:05 +0000 (17:34 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 14:56:30 +0000 (17:56 +0300)
 - this release drops the BMQ CPU scheduler, please see:
   https://gitlab.com/alfredchen/bmq/-/issues/16

Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-kernel/pf-sources/Manifest
sys-kernel/pf-sources/pf-sources-5.6_p5.ebuild [new file with mode: 0644]

index 00da1b5a989320c5427cee20afcbef2a9845cdb1..53e25908d99001e8cbf85d28f564cf42429bfdb6 100644 (file)
@@ -13,3 +13,4 @@ DIST pf-sources-5.6_p1.patch 278618 BLAKE2B 6ee7db469094b449c94ce70ebc5416b71be5
 DIST pf-sources-5.6_p2.patch 339203 BLAKE2B dabc89462ebf07316a16d77154a574e0bc1bfb28bf7643164fd281596eb7fb6507ee22432f658e43f10d4a079787b6f7274c39a407755a469fd42b4acdfb0022 SHA512 c487672b9e53f0c8dfd3326720fb23fc00536b704a709baa24d5f0d38ef892cdb8679a5158f2f6e00bf8ef69c6f0f619dcd9fd214c4f9c504c0e91ebd4d8175b
 DIST pf-sources-5.6_p3.patch 766739 BLAKE2B 98ab84a2e3c548989c06f6a3fd48fb35c2e59fc760c4716a4d334cd9c92fdd84fa8c66cc72f1ee422278df17216e4e8be2d597d8c3743f82203e8a5a3d02d7c0 SHA512 3439fbfc668d384b7d15550beb3cf8515ac357367666b37844b3f58002860d06ebd52b852bd88903b7e010893b3151524482d1faa4bc4f106513cdc8f771d905
 DIST pf-sources-5.6_p4.patch 848431 BLAKE2B 3313a8bb32b8b6bb79dd222796bd644a62cd792660fd04bff5e749800bbe4145b17d2131c002ebbd9f0ec7879e4527e4d5b7e38a625e3b08f66333920093c3eb SHA512 0df2c8ee0ea4d2aacb6c68e33b1234b0abc68be0a72198f17b59d5f71ff277f61a30e8ab5fbb472674470b4259eec716d8f071b62157248b5b60544e64a87bdb
+DIST pf-sources-5.6_p5.patch 861886 BLAKE2B edf1ea471d36a0a2bd715fd8822dfbdad475642ab7896c4583184d8d15d050cdbe7875d12d881f8cc71ccc84149cfda4f20c3f9580d4a87240be5f3fab2c4563 SHA512 b1b560737e20ffe6495c9e87b3ba265d7ba8d494b0572b84db74c76c0de5736e0260c917cb7f43c33a08d611f30e94fe7d438d0cfb9ff05fea0d5bc870eb8665
diff --git a/sys-kernel/pf-sources/pf-sources-5.6_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.6_p5.ebuild
new file mode 100644 (file)
index 0000000..e140e5f
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="2"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+       https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+       https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+       see: ${HOMEPAGE}."
+
+pkg_setup() {
+       ewarn ""
+       ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+       ewarn "If you need support, please contact the pf developers directly."
+       ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+       ewarn "the ebuilds. Thank you."
+       ewarn ""
+
+       kernel-2_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Temporary fix due to 5.6 iwlwifi mess
+       find "${S}" -name "10*linux*" -delete || die
+
+       kernel-2_src_prepare
+}
+
+pkg_postinst() {
+       kernel-2_pkg_postinst
+
+       elog "Optional features:"
+       optfeature "Userspace KSM helper" sys-process/uksmd
+}