dev-lang/yasm: remove obsolete hacks from src_prepare
authorMike Gilbert <floppym@gentoo.org>
Wed, 13 May 2020 23:11:27 +0000 (19:11 -0400)
committerMike Gilbert <floppym@gentoo.org>
Wed, 13 May 2020 23:11:27 +0000 (19:11 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-lang/yasm/yasm-9999.ebuild

index 5be4c7a9719bdfd27e2f9cde5befd76336b39f45..cf48d28e86239485dde0671c7e565dce73b45297 100644 (file)
@@ -4,11 +4,11 @@
 EAPI=7
 PYTHON_COMPAT=( python2_7 )
 
-inherit autotools eutils python-single-r1
+inherit python-single-r1
 
 if [[ ${PV} == 9999* ]] ; then
        EGIT_REPO_URI="https://github.com/yasm/yasm.git"
-       inherit git-r3
+       inherit autotools git-r3
 else
        SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
        KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
@@ -50,16 +50,8 @@ pkg_setup() {
 src_prepare() {
        default
 
-       if ! [[ ${PV} == 9999* ]]; then
-               sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
-       fi
-
-       # ksh doesn't grok $(xxx), makes aclocal fail
-       sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
-
-       eautoreconf
-
        if [[ ${PV} == 9999* ]]; then
+               eautoreconf
                ./modules/arch/x86/gen_x86_insn.py || die
        fi
 }